summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/pysize/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/pysize/files')
-rw-r--r--sys-fs/pysize/files/0.2-setuptools-automagic.patch12
-rw-r--r--sys-fs/pysize/files/psyco-0.2-automagic.patch20
2 files changed, 32 insertions, 0 deletions
diff --git a/sys-fs/pysize/files/0.2-setuptools-automagic.patch b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
new file mode 100644
index 000000000000..3e27c889f1a5
--- /dev/null
+++ b/sys-fs/pysize/files/0.2-setuptools-automagic.patch
@@ -0,0 +1,12 @@
+diff --git a/setup.py b/setup.py
+index 5550188..123d22c 100755
+--- a/setup.py
++++ b/setup.py
+@@ -2,7 +2,6 @@
+
+ import sys
+
+-sys.path.append('setuptools-0.7a1dev_r53614-py2.4.egg')
+ from setuptools import setup, find_packages
+ from pysize.version import VERSION
+
diff --git a/sys-fs/pysize/files/psyco-0.2-automagic.patch b/sys-fs/pysize/files/psyco-0.2-automagic.patch
new file mode 100644
index 000000000000..696f81fa4feb
--- /dev/null
+++ b/sys-fs/pysize/files/psyco-0.2-automagic.patch
@@ -0,0 +1,20 @@
+--- pysize/main.py 2007-03-11 16:09:53.000000000 +0100
++++ pysize/main.py.new 2009-01-02 00:08:43.384827054 +0100
+@@ -69,17 +69,8 @@
+ stats.print_stats(40)
+ os.remove(prof_file)
+
+-def _try_psyco():
+- try:
+- # Try to use psyco if available
+- import psyco
+- psyco.full()
+- except ImportError:
+- pass
+-
+ def main():
+ install_sigquit_traceback()
+- _try_psyco()
+ locale.setlocale(locale.LC_ALL, '')
+ usage = '%s [OPTIONS] [DIRECTORIES...]' % (sys.argv[0])
+ parser = optparse.OptionParser(usage=usage, version='pysize ' + VERSION)