summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-09-05 22:33:13 +0200
committerLars Wendler <polynomial-c@gentoo.org>2017-09-05 22:40:07 +0200
commit7a763126417c545024f2b88aeb70d210e48b9ad7 (patch)
treebca0c6dc21b58e4e7c6af1eb430e6693e9ac3fbb /sys-fs/quota/quota-4.04.ebuild
parentsys-fs/dd-rescue: Removed old. (diff)
downloadgentoo-7a763126417c545024f2b88aeb70d210e48b9ad7.tar.gz
gentoo-7a763126417c545024f2b88aeb70d210e48b9ad7.tar.bz2
gentoo-7a763126417c545024f2b88aeb70d210e48b9ad7.zip
sys-fs/quota: Bump to version 4.04
Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-fs/quota/quota-4.04.ebuild')
-rw-r--r--sys-fs/quota/quota-4.04.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/sys-fs/quota/quota-4.04.ebuild b/sys-fs/quota/quota-4.04.ebuild
new file mode 100644
index 000000000000..ab9d32e4f247
--- /dev/null
+++ b/sys-fs/quota/quota-4.04.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="
+ ldap? ( >=net-nds/openldap-2.3.35 )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:3
+ )
+ rpc? ( net-nds/rpcbind )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}"
+ $(use_enable nls)
+ $(use_enable ldap ldapmail)
+ $(use_enable netlink)
+ $(use_enable rpc)
+ $(use_enable rpc rpcsetquota)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins "${FILESDIR}"/ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe "${FILESDIR}"/ldap-scripts/*.pl
+ doexe "${FILESDIR}"/ldap-scripts/edquota_editor
+ fi
+}