summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2019-02-04 16:20:41 +0300
committerSergey Popov <pinkbyte@gentoo.org>2019-02-04 16:20:58 +0300
commitd61bafa81fc8d796dc0863ab0f11c41bca4bc25b (patch)
treea0b332abc7c7fba78325e349b62614f4610e253e /sys-fs/rarfs/rarfs-0.1.1-r2.ebuild
parentsci-mathematics/fricas: bump to 1.3.5 (diff)
downloadgentoo-d61bafa81fc8d796dc0863ab0f11c41bca4bc25b.tar.gz
gentoo-d61bafa81fc8d796dc0863ab0f11c41bca4bc25b.tar.bz2
gentoo-d61bafa81fc8d796dc0863ab0f11c41bca4bc25b.zip
sys-fs/rarfs: revision bump
Bump EAPI to 7. Use slotted sys-fs/fuse dependency Signed-off-by: Sergey Popov <pinkbyte@gentoo.org> Closes: https://bugs.gentoo.org/673638 Package-Manager: Portage-2.3.51, Repoman-2.3.10
Diffstat (limited to 'sys-fs/rarfs/rarfs-0.1.1-r2.ebuild')
-rw-r--r--sys-fs/rarfs/rarfs-0.1.1-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/sys-fs/rarfs/rarfs-0.1.1-r2.ebuild b/sys-fs/rarfs/rarfs-0.1.1-r2.ebuild
new file mode 100644
index 000000000000..3b6ab99a1ee8
--- /dev/null
+++ b/sys-fs/rarfs/rarfs-0.1.1-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-r1
+
+DESCRIPTION="Fuse module to mount uncompressed RAR archives"
+HOMEPAGE="https://sourceforge.net/projects/rarfs/"
+SRC_URI="mirror://sourceforge/rarfs/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README )
+
+src_install() {
+ dobin scripts/prarfs
+ python_replicate_script "${ED}/usr/bin/prarfs"
+
+ dobin src/rarfs
+ einstalldocs
+}