summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/siefs
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/siefs')
-rw-r--r--sys-fs/siefs/Manifest1
-rw-r--r--sys-fs/siefs/files/siefs-0.5-external-vmoconv.patch12
-rw-r--r--sys-fs/siefs/files/siefs-0.5-qa-fixes.patch55
-rw-r--r--sys-fs/siefs/metadata.xml5
-rw-r--r--sys-fs/siefs/siefs-0.5-r1.ebuild32
-rw-r--r--sys-fs/siefs/siefs-0.5-r2.ebuild33
6 files changed, 138 insertions, 0 deletions
diff --git a/sys-fs/siefs/Manifest b/sys-fs/siefs/Manifest
new file mode 100644
index 000000000000..7938f9db55c0
--- /dev/null
+++ b/sys-fs/siefs/Manifest
@@ -0,0 +1 @@
+DIST siefs-0.5.tar.gz 112466 SHA256 9e1d829de412446c7b2ce5ba1c9ca1f89206c42e8a510c920907d684e0b7f525
diff --git a/sys-fs/siefs/files/siefs-0.5-external-vmoconv.patch b/sys-fs/siefs/files/siefs-0.5-external-vmoconv.patch
new file mode 100644
index 000000000000..cb9688e24979
--- /dev/null
+++ b/sys-fs/siefs/files/siefs-0.5-external-vmoconv.patch
@@ -0,0 +1,12 @@
+diff -Nru siefs-0.5.orig/configure.in siefs-0.5/configure.in
+--- siefs-0.5.orig/configure.in 2005-04-04 05:15:31.000000000 +0000
++++ siefs-0.5/configure.in 2009-03-03 20:55:08.000000000 +0000
+@@ -50,7 +50,7 @@
+ AC_MSG_RESULT(${fuseinst})
+ AC_SUBST(fuseinst)
+
+-subdirs="siefs converter"
++subdirs="siefs"
+ AC_SUBST(subdirs)
+
+ AC_DEFINE_UNQUOTED(FUSEINST, "${fuseinst}")
diff --git a/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch b/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch
new file mode 100644
index 000000000000..dbd8a30fb1c7
--- /dev/null
+++ b/sys-fs/siefs/files/siefs-0.5-qa-fixes.patch
@@ -0,0 +1,55 @@
+diff -Nru siefs-0.5.orig/siefs/Makefile.am siefs-0.5/siefs/Makefile.am
+--- siefs-0.5.orig/siefs/Makefile.am 2005-04-05 14:36:28.000000000 +0000
++++ siefs-0.5/siefs/Makefile.am 2009-03-03 20:59:05.000000000 +0000
+@@ -9,8 +9,8 @@
+ slink_SOURCES = slink.c obex.c obex.h transport.c transport.h comm.c comm.h \
+ crcmodel.c crcmodel.h
+
+-LDADD = $(fuseinst)/lib/libfuse.a -lpthread
++LDADD = -lfuse -lpthread
+
+ install-exec-hook:
+- -rm -f /sbin/mount.siefs
+- -ln -s $(DESTDIR)$(bindir)/siefs /sbin/mount.siefs
++ -mkdir $(DESTDIR)/sbin/
++ -ln -s ..$(bindir)/siefs $(DESTDIR)/sbin/mount.siefs
+diff -Nru siefs-0.5.orig/siefs/charset.c siefs-0.5/siefs/charset.c
+--- siefs-0.5.orig/siefs/charset.c 2005-04-05 17:15:47.000000000 +0300
++++ siefs-0.5/siefs/charset.c 2007-05-23 14:13:19.000000000 +0300
+@@ -1,4 +1,5 @@
+ #include <stdio.h>
++#include <stdlib.h>
+ #include <string.h>
+ #include <ctype.h>
+
+diff -Nru siefs-0.5.orig/siefs/comm.c siefs-0.5/siefs/comm.c
+--- siefs-0.5.orig/siefs/comm.c 2005-04-05 02:53:38.000000000 +0300
++++ siefs-0.5/siefs/comm.c 2007-05-23 14:12:32.000000000 +0300
+@@ -15,6 +15,7 @@
+ #include <termios.h>
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <stdarg.h>
+ #include <errno.h>
+ #include "comm.h"
+@@ -114,7 +115,7 @@
+ if (fd < 0) return -1;
+ h->fd = fd;
+
+- bzero(&tio, sizeof(tio));
++ memset(&tio, 0, sizeof(tio));
+ f = commflags(h->speed);
+ if (f == -1) return -1;
+ tio.c_cflag = f;
+diff -Nru siefs-0.5.orig/siefs/transport.c siefs-0.5/siefs/transport.c
+--- siefs-0.5.orig/siefs/transport.c 2005-04-05 18:06:44.000000000 +0300
++++ siefs-0.5/siefs/transport.c 2007-05-23 14:13:00.000000000 +0300
+@@ -10,6 +10,7 @@
+
+ #include <stdio.h>
+ #include <stdlib.h>
++#include <string.h>
+ #include <errno.h>
+ #include "comm.h"
+ #include "crcmodel.h"
diff --git a/sys-fs/siefs/metadata.xml b/sys-fs/siefs/metadata.xml
new file mode 100644
index 000000000000..f7740ac73b8a
--- /dev/null
+++ b/sys-fs/siefs/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+</pkgmetadata>
diff --git a/sys-fs/siefs/siefs-0.5-r1.ebuild b/sys-fs/siefs/siefs-0.5-r1.ebuild
new file mode 100644
index 000000000000..8a9115a1c301
--- /dev/null
+++ b/sys-fs/siefs/siefs-0.5-r1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils
+
+DESCRIPTION="Siemens FS"
+HOMEPAGE="http://chaos.allsiemens.com/siefs"
+SRC_URI="http://chaos.allsiemens.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}/siefs"
+ epatch "${FILESDIR}"/${P}-qa-fixes.patch
+
+ sed -i "s:-rm -f /sbin/mount.siefs:-mkdir \$(DESTDIR)/sbin/:" Makefile.in
+ sed -i "s:-ln -s \$(DESTDIR)\$(bindir)/siefs /sbin/mount.siefs:-ln -s ..\$(bindir)/siefs \$(DESTDIR)/sbin/mount.siefs:" Makefile.in
+ sed -i "s:LDADD = \$(fuseinst)/lib/libfuse.a:LDADD = -lfuse:" Makefile.in
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS
+}
diff --git a/sys-fs/siefs/siefs-0.5-r2.ebuild b/sys-fs/siefs/siefs-0.5-r2.ebuild
new file mode 100644
index 000000000000..f580d9e6a870
--- /dev/null
+++ b/sys-fs/siefs/siefs-0.5-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="Siemens FS"
+HOMEPAGE="http://chaos.allsiemens.com/siefs"
+SRC_URI="http://chaos.allsiemens.com/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+DEPEND="sys-fs/fuse"
+RDEPEND="${DEPEND}
+ app-mobilephone/vmoconv"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-qa-fixes.patch
+ epatch "${FILESDIR}"/${P}-external-vmoconv.patch
+
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc README AUTHORS
+}