summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-12-03 09:53:09 -0500
committerMatt Turner <mattst88@gentoo.org>2022-12-03 09:55:38 -0500
commit990047cd89225b0ce59fb2d3fe375a2ccd80a668 (patch)
treef7a2fe523a7fcc4efcc5f7514d476e4125e570fa /sys-fs/squashfs-tools-ng
parentx11-misc/sddm: Stabilize 0.18.1-r8 x86, #883289 (diff)
downloadgentoo-990047cd89225b0ce59fb2d3fe375a2ccd80a668.tar.gz
gentoo-990047cd89225b0ce59fb2d3fe375a2ccd80a668.tar.bz2
gentoo-990047cd89225b0ce59fb2d3fe375a2ccd80a668.zip
sys-fs/squashfs-tools-ng: Version bump to 1.2.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools-ng')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild52
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild11
3 files changed, 59 insertions, 5 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 4cf22da07222..5dd981d9a165 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-ng-1.1.4.tar.xz 1311684 BLAKE2B b976ac223d57919958e0ad04c989e0a9cf2837e1c7ef1e1962069b4796b492fe2fc99c59d1e38b11e380226dc2fc4b2e25e29244635a32d03d0667f2b3ef1d7f SHA512 10e0bebd70de686862f1473588cdbf922ad766c86b64ebd4d6338fd863f862fe0c9374950fa54a197c0f02021c63943cf1ba57ebb7f93a4188e68e2b25b4a800
+DIST squashfs-tools-ng-1.2.0.tar.xz 586992 BLAKE2B ca20e4e01033b4dfa3ada2abd0f618305cb3f49f683863d36ea93679c2cfc0c396ee209c3254fa318d30cb2c4c000c3634d4b625212842cabae0a5e53b4a2bdc SHA512 0c52890a92e2aee928db3e2407c087703d331e9dd8cba1b58ef44fe78cdd7ed1523e9b0485f7da83ad77423ffdccaf392a2b752ad948d62a5f1b5e600b523070
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
new file mode 100644
index 000000000000..d5956518b2df
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.2.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 2019-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 +lzma lzo selinux +tools zstd"
+
+DEPEND="
+ app-arch/bzip2:=
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with lzma xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
index a9e2e335faeb..d5956518b2df 100644
--- a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 2019-2021 Gentoo Authors
+# Copyright 2019-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="A new set of tools for working with SquashFS images"
HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
@@ -13,15 +13,16 @@ else
SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
fi
-LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+LICENSE="LGPL-3+ BSD-2 MIT tools? ( GPL-3+ )"
SLOT="0"
IUSE="lz4 +lzma lzo selinux +tools zstd"
DEPEND="
+ app-arch/bzip2:=
sys-libs/zlib:=
lz4? ( app-arch/lz4:= )
- lzma? ( app-arch/xz-utils:= )
- lzo? ( dev-libs/lzo:= )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo:2 )
selinux? ( sys-libs/libselinux:= )
zstd? ( app-arch/zstd:= )
"