summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-27 12:51:05 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-27 13:00:11 +0100
commita9a132b4df2d619e92909da7ce4701c0e227dcd6 (patch)
tree8276e8b94d678a76930ba20cb7518ed309daf365 /sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
parentdev-libs/sord: arm stable wrt bug #706050 (diff)
downloadgentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.tar.gz
gentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.tar.bz2
gentoo-a9a132b4df2d619e92909da7ce4701c0e227dcd6.zip
sys-fs/squashfs-tools: Fix CFLAGS=-fno-common
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Closes: https://bugs.gentoo.org/706456 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild')
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild11
1 files changed, 6 insertions, 5 deletions
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
index ae823c3e1979..fcc3ce5bf79e 100644
--- a/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -30,7 +30,9 @@ DEPEND="
${RDEPEND}
static? ( ${LIB_DEPEND} )
"
-S=${WORKDIR}/${P}/${PN}
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.4-fno-common.patch
+)
use10() { usex $1 1 0 ; }
@@ -55,12 +57,11 @@ src_configure() {
}
src_compile() {
- emake "${EMAKE_SQUASHFS_CONF[@]}"
+ emake "${EMAKE_SQUASHFS_CONF[@]}" -C ${PN}
}
src_install() {
- dobin mksquashfs unsquashfs
- cd ..
+ dobin ${PN}/{mksquashfs,unsquashfs}
dodoc ACKNOWLEDGEMENTS CHANGES README*
dodoc -r RELEASE-READMEs
}