summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/sshfs-fuse
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/sshfs-fuse')
-rw-r--r--sys-fs/sshfs-fuse/Manifest2
-rw-r--r--sys-fs/sshfs-fuse/metadata.xml8
-rw-r--r--sys-fs/sshfs-fuse/sshfs-fuse-2.4.ebuild28
-rw-r--r--sys-fs/sshfs-fuse/sshfs-fuse-2.5.ebuild28
4 files changed, 66 insertions, 0 deletions
diff --git a/sys-fs/sshfs-fuse/Manifest b/sys-fs/sshfs-fuse/Manifest
new file mode 100644
index 000000000000..eefdb8893e25
--- /dev/null
+++ b/sys-fs/sshfs-fuse/Manifest
@@ -0,0 +1,2 @@
+DIST sshfs-fuse-2.4.tar.gz 132930 SHA256 3c93ba8522568093c94ff9c5a3763929380dd229365d905769ff82475d774dd1 SHA512 2f73d2163052f815bba65ad4a33a12626cd76628cd90df80378f3d045c61df7b0b4e7e5eec744e2adf44bdd1814cfc454d705eb74914ad4586f8835a926073de WHIRLPOOL 9773ca67c384dabc8122eaf08a27cb63f2cbdfb558d5cf2c581db2e8355801f93370763963d1f301a3504ef4bea80add1f6dadc6846c73847c5c056b4c0e394b
+DIST sshfs-fuse-2.5.tar.gz 136378 SHA256 e9171452e5d0150b9c6a2158fd2e2dcefb5d5d03ba4d208949e00a3a46c6e63e SHA512 48ae4008d10fe66b843ff1e891627f8262e00d064fec048c8c1189507e757994e81e4fa2deb4d8d56cff0d1818efe4a692494b9c48a01c6c79c626acefa1b53e WHIRLPOOL 00086691d287a770ce04ed068250841fe9fd8ec054a9f86f2ffd388c5c519b4f6bc559990724d25895065d6ab8618eb07129801c32a68eb9bfefb8fa952a412f
diff --git a/sys-fs/sshfs-fuse/metadata.xml b/sys-fs/sshfs-fuse/metadata.xml
new file mode 100644
index 000000000000..e93f1bcba449
--- /dev/null
+++ b/sys-fs/sshfs-fuse/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>kernel-misc</herd>
+ <upstream>
+ <remote-id type="sourceforge">fuse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/sys-fs/sshfs-fuse/sshfs-fuse-2.4.ebuild b/sys-fs/sshfs-fuse/sshfs-fuse-2.4.ebuild
new file mode 100644
index 000000000000..0ff654b5af62
--- /dev/null
+++ b/sys-fs/sshfs-fuse/sshfs-fuse-2.4.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
+HOMEPAGE="http://fuse.sourceforge.net/sshfs.html"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.3"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README NEWS ChangeLog AUTHORS FAQ.txt )
+
+src_configure() {
+ # hack not needed with >=net-misc/openssh-4.3
+ econf --disable-sshnodelay
+}
diff --git a/sys-fs/sshfs-fuse/sshfs-fuse-2.5.ebuild b/sys-fs/sshfs-fuse/sshfs-fuse-2.5.ebuild
new file mode 100644
index 000000000000..0ff654b5af62
--- /dev/null
+++ b/sys-fs/sshfs-fuse/sshfs-fuse-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+DESCRIPTION="Fuse-filesystem utilizing the sftp service"
+SRC_URI="mirror://sourceforge/fuse/${P}.tar.gz"
+HOMEPAGE="http://fuse.sourceforge.net/sshfs.html"
+
+LICENSE="GPL-2"
+KEYWORDS="amd64 arm hppa ~ppc ~ppc64 x86 ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux"
+SLOT="0"
+IUSE=""
+
+CDEPEND=">=sys-fs/fuse-2.6.0_pre3
+ >=dev-libs/glib-2.4.2"
+RDEPEND="${CDEPEND}
+ >=net-misc/openssh-4.3"
+DEPEND="${CDEPEND}
+ virtual/pkgconfig"
+
+DOCS=( README NEWS ChangeLog AUTHORS FAQ.txt )
+
+src_configure() {
+ # hack not needed with >=net-misc/openssh-4.3
+ econf --disable-sshnodelay
+}