summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-01-07 06:30:10 +0100
committerMichał Górny <mgorny@gentoo.org>2020-01-07 07:02:04 +0100
commit8cf8410241fc77b097c9909cd6156dcb5a9eb6dc (patch)
treec997ab1bfd89e768ac9a1e7ad88050e9a66937ea /sys-fs/vhba/vhba-20200106.ebuild
parentx11-misc/rofi-calc: new ebuild (diff)
downloadgentoo-8cf8410241fc77b097c9909cd6156dcb5a9eb6dc.tar.gz
gentoo-8cf8410241fc77b097c9909cd6156dcb5a9eb6dc.tar.bz2
gentoo-8cf8410241fc77b097c9909cd6156dcb5a9eb6dc.zip
sys-fs/vhba: Bump to 20200106
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs/vhba/vhba-20200106.ebuild')
-rw-r--r--sys-fs/vhba/vhba-20200106.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/sys-fs/vhba/vhba-20200106.ebuild b/sys-fs/vhba/vhba-20200106.ebuild
new file mode 100644
index 000000000000..588db552a4bf
--- /dev/null
+++ b/sys-fs/vhba/vhba-20200106.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit eutils linux-mod udev
+
+MY_P=vhba-module-${PV}
+DESCRIPTION="Virtual (SCSI) Host Bus Adapter kernel module for the CDEmu suite"
+HOMEPAGE="https://cdemu.sourceforge.io"
+SRC_URI="https://download.sourceforge.net/cdemu/vhba-module/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="virtual/udev"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${MY_P}
+MODULE_NAMES="vhba(block:${S})"
+BUILD_TARGETS=modules
+
+pkg_setup() {
+ CONFIG_CHECK="~BLK_DEV_SR ~CHR_DEV_SG"
+ check_extra_config
+ BUILD_PARAMS="KDIR=${KV_OUT_DIR}"
+ linux-mod_pkg_setup
+}
+
+src_prepare() {
+ # Avoid -Werror problems
+ sed -i -e '/ccflags/s/-Werror/-Wall/' Makefile || die "sed failed"
+
+ eapply_user
+}
+
+src_install() {
+ dodoc AUTHORS ChangeLog README
+ linux-mod_src_install
+
+ einfo "Generating udev rules ..."
+ udev_newrules - 69-vhba.rules <<-EOF
+ # do not edit this file, it will be overwritten on update
+ #
+ KERNEL=="vhba_ctl", SUBSYSTEM=="misc", TAG+="uaccess"
+ EOF
+}