summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-fs/vzquota
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-fs/vzquota')
-rw-r--r--sys-fs/vzquota/Manifest1
-rw-r--r--sys-fs/vzquota/metadata.xml8
-rw-r--r--sys-fs/vzquota/vzquota-3.1.ebuild31
3 files changed, 40 insertions, 0 deletions
diff --git a/sys-fs/vzquota/Manifest b/sys-fs/vzquota/Manifest
new file mode 100644
index 000000000000..1d57fa7ad025
--- /dev/null
+++ b/sys-fs/vzquota/Manifest
@@ -0,0 +1 @@
+DIST vzquota-3.1.tar.bz2 46848 SHA256 749a2d1b2659fdcd5d43b299ad9152bbf029e1889a3c5cf8fe941c0b156fc4a3 SHA512 e2289df9235149c8d511a6b2846f672574622fb39ca5cd8f5780af9a4cc204ce12f1a2ecd0382143c04eca93e64ce6851caab0782e8ad178352954ca599ffaac WHIRLPOOL c9a2e4a604a3520fbc66191b2e357170bb1a5bc7e4bf1eb4bf265381deb701493cb2aeb3c941a6d26036772bf2e4fcec1c01d7497ee01436f2fe07e2ef8eddd6
diff --git a/sys-fs/vzquota/metadata.xml b/sys-fs/vzquota/metadata.xml
new file mode 100644
index 000000000000..1aecc7ea300a
--- /dev/null
+++ b/sys-fs/vzquota/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+<email>pva@gentoo.org</email>
+<name>Peter Volkov</name>
+</maintainer>
+</pkgmetadata>
diff --git a/sys-fs/vzquota/vzquota-3.1.ebuild b/sys-fs/vzquota/vzquota-3.1.ebuild
new file mode 100644
index 000000000000..defd5971055c
--- /dev/null
+++ b/sys-fs/vzquota/vzquota-3.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit toolchain-funcs
+
+DESCRIPTION="OpenVZ VPS disk quota utility"
+HOMEPAGE="http://openvz.org/download/utils/vzquota/"
+SRC_URI="http://download.openvz.org/utils/${PN}/${PV}/src/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ~ppc64 ~sparc x86"
+IUSE=""
+
+src_prepare() {
+ sed -e 's,$(INSTALL) -s -m,$(INSTALL) -m,' \
+ -e 's:$(CC) $(CFLAGS) -o:$(CC) $(CFLAGS) $(LDFLAGS) -o:' \
+ -e 's:-Werror ::' \
+ -i "${S}/src/Makefile" || die 'sed on src/Makefile failed'
+ tc-export CC
+}
+
+src_install() {
+ emake DESTDIR="${ED}" INSTALL="${EPREFIX}/usr/bin/install" install
+ keepdir /var/vzquota
+ # remove accidentally created man8 dir
+ rm -r "${ED}/man8" || die 'remove man8 directory failed'
+}