summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-11-17 12:09:20 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-11-17 12:10:38 +0100
commite2de10880a06035742b7e32d68b6932b027e59aa (patch)
treedc757cd5c92d97932c1cb4f378b7147340166575 /sys-fs/xfsdump/xfsdump-3.1.6.ebuild
parentdev-python/werkzeug: Version Bump (diff)
downloadgentoo-e2de10880a06035742b7e32d68b6932b027e59aa.tar.gz
gentoo-e2de10880a06035742b7e32d68b6932b027e59aa.tar.bz2
gentoo-e2de10880a06035742b7e32d68b6932b027e59aa.zip
sys-fs/xfsdump: Bump to version 3.1.6
Package-Manager: portage-2.2.24 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs/xfsdump/xfsdump-3.1.6.ebuild')
-rw-r--r--sys-fs/xfsdump/xfsdump-3.1.6.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/sys-fs/xfsdump/xfsdump-3.1.6.ebuild b/sys-fs/xfsdump/xfsdump-3.1.6.ebuild
new file mode 100644
index 000000000000..935ff6455437
--- /dev/null
+++ b/sys-fs/xfsdump/xfsdump-3.1.6.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+inherit multilib eutils
+
+DESCRIPTION="xfs dump/restore utilities"
+HOMEPAGE="http://oss.sgi.com/projects/xfs"
+SRC_URI="ftp://oss.sgi.com/projects/xfs/cmd_tars/${P}.tar.gz
+ ftp://oss.sgi.com/projects/xfs/previous/cmd_tars/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-fs/e2fsprogs
+ >=sys-fs/xfsprogs-3.2.0
+ sys-apps/dmapi
+ >=sys-apps/attr-2.4.19"
+DEPEND="${RDEPEND}
+ sys-devel/gettext"
+
+src_prepare() {
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in \
+ || die
+ epatch "${FILESDIR}"/${PN}-3.0.5-prompt-overflow.patch #335115
+ epatch "${FILESDIR}"/${PN}-3.0.4-no-symlink.patch #311881
+}
+
+src_configure() {
+ unset PLATFORM #184564
+ export OPTIMIZER=${CFLAGS}
+ export DEBUG=-DNDEBUG
+
+ econf \
+ --libdir="${EPREFIX}/$(get_libdir)" \
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)" \
+ --sbindir="${EPREFIX}/sbin"
+}