summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Gerstner <Matthias.Gerstner@nefkom.net>2020-05-13 17:51:37 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-06-08 10:45:20 +0300
commit427517aab91f283b7c88e9c82fc4c9432783ef58 (patch)
treece8a77ecd95c7eaec86fcef28e714d8355e6befe /sys-fs/xwmfs/xwmfs-0.85.ebuild
parentdev-python/pythondialog: use distutils-r1 eclass for 'docs' IUSE (diff)
downloadgentoo-427517aab91f283b7c88e9c82fc4c9432783ef58.tar.gz
gentoo-427517aab91f283b7c88e9c82fc4c9432783ef58.tar.bz2
gentoo-427517aab91f283b7c88e9c82fc4c9432783ef58.zip
sys-fs/xwmfs: version bump to 0.85
Signed-off-by: Matthias Gerstner <matthias.gerstner@nefkom.net> Package-Manager: Portage-2.3.89, Repoman-2.3.20 Closes: https://bugs.gentoo.org/722140 Closes: https://bugs.gentoo.org/716170 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs/xwmfs/xwmfs-0.85.ebuild')
-rw-r--r--sys-fs/xwmfs/xwmfs-0.85.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/xwmfs/xwmfs-0.85.ebuild b/sys-fs/xwmfs/xwmfs-0.85.ebuild
new file mode 100644
index 000000000000..1f23a8953190
--- /dev/null
+++ b/sys-fs/xwmfs/xwmfs-0.85.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="FUSE-based X11 Window-Manager file system"
+HOMEPAGE="https://github.com/gerstner-hub/xwmfs"
+SRC_URI="https://github.com/gerstner-hub/${PN}/releases/download/v${PV}/${P}-dist.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0"
+
+RDEPEND="
+ sys-fs/fuse:0=
+ >=x11-libs/libX11-1.6.5"
+
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_test() {
+ # unset display to avoid testing errors, tests rely on X11 and a window
+ # manager environment
+ unset DISPLAY
+
+ default
+}