summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoshua Kinard <kumba@gentoo.org>2020-02-26 22:22:00 -0500
committerJoshua Kinard <kumba@gentoo.org>2020-02-26 22:22:00 -0500
commit62c1c99f07ffef5001eb361c1614ca67b4f44b3f (patch)
tree3427a0d9c7e98595da5cd062932e6960e60a9ccd /sys-fs/zerofree/zerofree-1.1.1.ebuild
parentdev-util/schroot: drop old (diff)
downloadgentoo-62c1c99f07ffef5001eb361c1614ca67b4f44b3f.tar.gz
gentoo-62c1c99f07ffef5001eb361c1614ca67b4f44b3f.tar.bz2
gentoo-62c1c99f07ffef5001eb361c1614ca67b4f44b3f.zip
sys-fs/zerofree: Version bump, replace sed delimiter
- Add ebuild for zerofree-1.1.1 - Replace colon sed delimiter w/ pipe to resolve #710818 - Bump to EAPI 7 - Remove useless src_compile and use the built-in default Signed-off-by: Joshua Kinard <kumba@gentoo.org> Package-Manager: Portage-2.3.89, Repoman-2.3.20
Diffstat (limited to 'sys-fs/zerofree/zerofree-1.1.1.ebuild')
-rw-r--r--sys-fs/zerofree/zerofree-1.1.1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/zerofree/zerofree-1.1.1.ebuild b/sys-fs/zerofree/zerofree-1.1.1.ebuild
new file mode 100644
index 000000000000..6e360c833a18
--- /dev/null
+++ b/sys-fs/zerofree/zerofree-1.1.1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Zeroes out all free space on a filesystem"
+HOMEPAGE="http://frippery.org/uml/index.html"
+SRC_URI="http://frippery.org/uml/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~x86"
+IUSE=""
+
+DEPEND="sys-libs/e2fsprogs-libs"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ # Honor system CFLAGS.
+ # Use pipes for the sed delimiter to resolve #710818.
+ sed -i \
+ -e "s|CC=gcc|CC=$(tc-getCC)\nCFLAGS=${CFLAGS}\nLDFLAGS=${LDFLAGS}|g" \
+ -e "s|-o zerofree|\$(CFLAGS) \$(LDFLAGS) -o zerofree|g" \
+ -e "/-lext2fs/{ s|-lext2fs||g; s|$| -lext2fs|g; }" \
+ Makefile || die "Failed to sed the Makefile"
+
+ eapply_user
+}
+
+src_install() {
+ # Install into /sbin
+ into /
+ dosbin zerofree
+}