summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-22 18:00:48 +0000
committerSam James <sam@gentoo.org>2022-03-22 18:01:09 +0000
commit2f73f5b8ed0602bdf8a0d7fbfb9643cb3a9740bd (patch)
treeb08e5d41dd67acd6397ff5a8cbe21f1da52ce9ac /sys-fs/zfs-kmod
parentsci-misc/flashdot: don't call svn (diff)
downloadgentoo-2f73f5b8ed0602bdf8a0d7fbfb9643cb3a9740bd.tar.gz
gentoo-2f73f5b8ed0602bdf8a0d7fbfb9643cb3a9740bd.tar.bz2
gentoo-2f73f5b8ed0602bdf8a0d7fbfb9643cb3a9740bd.zip
sys-fs/zfs-kmod: fix -Werror issue
Closes: https://bugs.gentoo.org/835646 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/files/2.1.3-werror.patch30
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-2.1.3.ebuild4
2 files changed, 34 insertions, 0 deletions
diff --git a/sys-fs/zfs-kmod/files/2.1.3-werror.patch b/sys-fs/zfs-kmod/files/2.1.3-werror.patch
new file mode 100644
index 000000000000..b4aba47d8324
--- /dev/null
+++ b/sys-fs/zfs-kmod/files/2.1.3-werror.patch
@@ -0,0 +1,30 @@
+https://bugs.gentoo.org/835646
+https://github.com/openzfs/zfs/commit/7b215d93bcc0a72d7020ccc050c64f39aa7f2be8.patch
+
+From: Ryan Moeller <freqlabs@FreeBSD.org>
+Date: Thu, 17 Mar 2022 13:18:23 -0400
+Subject: [PATCH] Fix module build with -Werror
+
+This is a direct commit to zfs-2.1-release to fix release builds that
+error out on an unused variable. The issue is avoided on master by a
+huge series of commits that change how the ASSERT macros work, but that
+is not feasible to backport.
+
+Reviewed-by: Tony Hutter <hutter2@llnl.gov>
+Reviewed-by: Brian Behlendorf <behlendorf1@llnl.gov>
+Reviewed-by: Igor Kozhukhov <igor@dilos.org>
+Signed-off-by: Ryan Moeller <freqlabs@FreeBSD.org>
+Closes #13194
+Closes #13196
+--- a/module/zfs/arc.c
++++ b/module/zfs/arc.c
+@@ -1205,7 +1205,7 @@ static void
+ hdr_l2only_dest(void *vbuf, void *unused)
+ {
+ (void) unused;
+- arc_buf_hdr_t *hdr = vbuf;
++ arc_buf_hdr_t *hdr __maybe_unused = vbuf;
+
+ ASSERT(HDR_EMPTY(hdr));
+ arc_space_return(HDR_L2ONLY_SIZE, ARC_SPACE_L2HDRS);
+
diff --git a/sys-fs/zfs-kmod/zfs-kmod-2.1.3.ebuild b/sys-fs/zfs-kmod/zfs-kmod-2.1.3.ebuild
index 2c6ab28bcfde..39f9cc590a1a 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-2.1.3.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-2.1.3.ebuild
@@ -62,6 +62,10 @@ RESTRICT="debug? ( strip ) test"
DOCS=( AUTHORS COPYRIGHT META README.md )
+PATCHES=(
+ "${FILESDIR}"/${PV}-werror.patch
+)
+
pkg_pretend() {
use rootfs || return 0