summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-07 15:04:12 -0800
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2021-11-07 15:57:43 -0800
commit8de8847f3b466c59f70a0da8fd01696702fec7eb (patch)
treee7ea69af2b8fad5dd3728ec46cc9f0cf08314c06 /sys-fs/zfs-kmod
parentsys-fs/zfs: drop 2.1.1-r2 (diff)
downloadgentoo-8de8847f3b466c59f70a0da8fd01696702fec7eb.tar.gz
gentoo-8de8847f3b466c59f70a0da8fd01696702fec7eb.tar.bz2
gentoo-8de8847f3b466c59f70a0da8fd01696702fec7eb.zip
sys-fs/zfs-kmod: sync live ebuild
Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'sys-fs/zfs-kmod')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild13
1 files changed, 12 insertions, 1 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index 255ef48a0b4b..5b11d92a6ea3 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -21,6 +21,10 @@ else
S="${WORKDIR}/zfs-${PV%_rc?}"
ZFS_KERNEL_COMPAT="5.14"
+ # increments minor eg 5.14 -> 5.15, and still supports override.
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_COMPAT_OVERRIDE:-${ZFS_KERNEL_COMPAT}}"
+ ZFS_KERNEL_DEP="${ZFS_KERNEL_DEP%%.*}.$(( ${ZFS_KERNEL_DEP##*.} + 1))"
+
if [[ ${PV} != *_rc* ]]; then
KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv"
fi
@@ -39,8 +43,15 @@ BDEPEND="
virtual/awk
"
+# we want dist-kernel block in BDEPEND because of portage resolver.
+# since linux-mod.eclass already sets version-unbounded dep, portage
+# will pull new versions. So we set it in BDEPEND which takes priority.
+# and we don't need in in git ebuild.
if [[ ${PV} != "9999" ]] ; then
- BDEPEND+=" verify-sig? ( app-crypt/openpgp-keys-openzfs )"
+ BDEPEND+="
+ verify-sig? ( app-crypt/openpgp-keys-openzfs )
+ dist-kernel? ( <virtual/dist-kernel-${ZFS_KERNEL_DEP}:= )
+ "
fi
# PDEPEND in this form is needed to trick portage suggest