summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-03-28 20:55:13 -0400
committerMatt Turner <mattst88@gentoo.org>2021-03-28 20:55:13 -0400
commit0ecfd8f5676b874d1838990a9296a3cf4ef6a8e5 (patch)
tree0fde1d79b46474ce877339ccfdc60ce2ec46355f /sys-fs
parentdev-python/cryptography: Keyword 3.4.7 alpha, #778401 (diff)
downloadgentoo-0ecfd8f5676b874d1838990a9296a3cf4ef6a8e5.tar.gz
gentoo-0ecfd8f5676b874d1838990a9296a3cf4ef6a8e5.tar.bz2
gentoo-0ecfd8f5676b874d1838990a9296a3cf4ef6a8e5.zip
sys-fs/squashfs-tools-ng: Version bump to 1.1.0
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.0.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 96953e6a9a48..ac6467197b20 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,2 +1,3 @@
DIST squashfs-tools-ng-1.0.3.tar.xz 1101820 BLAKE2B f21cef44d5dc3cae01733bb720ba472d02777d2b69a3e428dbf4d0f64ad46a18131dae807a9ef719e29698b06ff04a82de1906876c40aef336aa57a75eb3fde3 SHA512 32e0084b1343de07b450e5337398618475a57c91c6f351c73bb7aa3dd6b5dc83aeca924f3d624ce802c9e1d600389a76cbca7b841104259d32f3ef2c7f13db67
DIST squashfs-tools-ng-1.0.4.tar.xz 1103996 BLAKE2B c56b02932cdb4116fcec582f674771f27f67cbec51ca8d31beb1fbccef72fd06a82ee5981fb2dd5f6e7297180d1774d856c24ae447e95687f6f7b970357b807c SHA512 c0a24be6b07739713213fc5936506ea7c1f62fa461f60955986ac4dda6958203e74336418abe615ecc85c62deb085039ca375891538ae01c21672d4911091614
+DIST squashfs-tools-ng-1.1.0.tar.xz 1169556 BLAKE2B 87222e87176a69aef39130af9e6d9b23d9e2f81e10680eb26236260ebe50dedcfbba33785d739a98a152825e535d0d166f7ce08262157341a6ef48d1d2ef33e0 SHA512 06b76fb8bb4295ac451bc98cbe757b272ac831c2ec146803b4813b9792486372691864fcaaa1a3cac6628608ac62cf081f1aa331c0802ea1a9858461fef33923
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.0.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.0.ebuild
new file mode 100644
index 000000000000..22a2dbc93b62
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-1.1.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}