summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-02-16 18:33:34 +0000
committerSam James <sam@gentoo.org>2021-02-16 18:39:31 +0000
commit1e4d93e0a4d4eb90f52f5c074f7548ca49416ec7 (patch)
tree32e77d304690aa13a753675d0e24c3f7c4142b51 /sys-fs
parentsys-fs/compsize: bump to 1.5 (diff)
downloadgentoo-1e4d93e0a4d4eb90f52f5c074f7548ca49416ec7.tar.gz
gentoo-1e4d93e0a4d4eb90f52f5c074f7548ca49416ec7.tar.bz2
gentoo-1e4d93e0a4d4eb90f52f5c074f7548ca49416ec7.zip
sys-fs/compsize: respect CC
Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/compsize/compsize-1.5.ebuild4
-rw-r--r--sys-fs/compsize/compsize-9999.ebuild4
2 files changed, 6 insertions, 2 deletions
diff --git a/sys-fs/compsize/compsize-1.5.ebuild b/sys-fs/compsize/compsize-1.5.ebuild
index f00e46619d53..471c60d719d1 100644
--- a/sys-fs/compsize/compsize-1.5.ebuild
+++ b/sys-fs/compsize/compsize-1.5.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
HOMEPAGE="https://github.com/kilobyte/compsize"
@@ -29,6 +29,8 @@ src_prepare() {
}
src_configure() {
+ tc-export CC
+
use debug && append-cflags -Wall -DDEBUG -g
default
}
diff --git a/sys-fs/compsize/compsize-9999.ebuild b/sys-fs/compsize/compsize-9999.ebuild
index f00e46619d53..471c60d719d1 100644
--- a/sys-fs/compsize/compsize-9999.ebuild
+++ b/sys-fs/compsize/compsize-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit flag-o-matic
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Utility to find btrfs compression type/ratio on a file or set of files"
HOMEPAGE="https://github.com/kilobyte/compsize"
@@ -29,6 +29,8 @@ src_prepare() {
}
src_configure() {
+ tc-export CC
+
use debug && append-cflags -Wall -DDEBUG -g
default
}