summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-04-29 19:32:10 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-04-29 19:59:19 +0200
commit1e99186f1471d40274f09df44800525a640cdab2 (patch)
treeece83345bf3766a3b08f54901cd2a63cb07cf983 /sys-fs
parentx11-themes/gtk-engines-nodoka: Fix the build with slibtool (diff)
downloadgentoo-1e99186f1471d40274f09df44800525a640cdab2.tar.gz
gentoo-1e99186f1471d40274f09df44800525a640cdab2.tar.bz2
gentoo-1e99186f1471d40274f09df44800525a640cdab2.zip
sys-fs/dd-rescue: Bump to version 1.99.11
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/dd-rescue/Manifest1
-rw-r--r--sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild105
-rw-r--r--sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch30
3 files changed, 136 insertions, 0 deletions
diff --git a/sys-fs/dd-rescue/Manifest b/sys-fs/dd-rescue/Manifest
index c8efdcb67ef6..e413d45aa7ef 100644
--- a/sys-fs/dd-rescue/Manifest
+++ b/sys-fs/dd-rescue/Manifest
@@ -1,3 +1,4 @@
DIST dd_rescue-1.99.10.tar.bz2 176603 BLAKE2B 66e9f54274363eb9b66c3fb098d398f7ae6f43812eb1560304c14bbe4b0e8158881f891a80ef2b03a77d205402651c7b9ed8bcdc14b3e6e865f4e713ab9249f4 SHA512 8f7cd4fca09302035f26102ce057a05130dcd808f2e44bd057f776dcd0222f9df6317b9703ab6c3b133a55e4bbbdf0ff58fdcbbbc3f1fc20889b29092b522e06
+DIST dd_rescue-1.99.11.tar.bz2 181927 BLAKE2B 8cd4db6cb8d85962e4cea50b0006fdbe5f085fbcf7bdbfe4d0fab1fe33412c1379317f54429c76ed1d905e32d5e791869fa27f2f14917cb1c3842fc6caca2a12 SHA512 e1d32711421ebbafd80fd210718667ff8c2d22b5349945105b3e4c29d54d381385b1fd188b2d8aa1b7a0aaf2cc9d8f7374373cff3992726a3d17549ca50f3904
DIST dd_rescue-1.99.8.tar.bz2 174594 BLAKE2B 51e62989bf6318cb5926f30bc1db746bddd41fb49aab15dc2b1c67e0af079469161d390ba4e1e109d195249b3aace3aa830a3aec14ba534eb47f38c0136f910c SHA512 a230e1df4532671ea631036012dd1e38614e45bed58b00757f0017b0ea60f14ac3bdac07777d175aa4929def593b3c8485e463b1fc25b5067adf4cf3f3ac040d
DIST dd_rescue-1.99.9.tar.bz2 176015 BLAKE2B b0955182eaa9fff967e77278de8a5582b3ad75861f1279cf8aea47a5c50925692f2223408444f6c73a38b67bee9738df0ce2cf60b262e86d5d32c26d59aab97d SHA512 f181f33b80637da09f8c47efe2961b0c272540bb9df932a1e6714d3e3018b1ec251f9bca8473b04bb84673812fe68a4f12fd9cc72d2340b5246a7ac25b7f8238
diff --git a/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild b/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild
new file mode 100644
index 000000000000..f4c2898623cf
--- /dev/null
+++ b/sys-fs/dd-rescue/dd-rescue-1.99.11.ebuild
@@ -0,0 +1,105 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools flag-o-matic multilib toolchain-funcs
+
+MY_PN="${PN/-/_}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Similar to dd but can copy from source with errors"
+HOMEPAGE="http://www.garloff.de/kurt/linux/ddrescue/"
+SRC_URI="http://www.garloff.de/kurt/linux/ddrescue/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cpu_flags_x86_avx2 lzo cpu_flags_x86_sse4_2 static xattr"
+
+RDEPEND="lzo? ( dev-libs/lzo )
+ xattr? ( sys-apps/attr )"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.99.11-musl-r2.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use cpu_flags_x86_sse4_2; then
+ sed -i \
+ -e 's:^CC_FLAGS_CHECK(-msse4.2,SSE42):#&:' \
+ configure.ac || die
+ fi
+
+ if ! use cpu_flags_x86_avx2; then
+ sed -i \
+ -e 's:^CC_FLAGS_CHECK(-mavx2,AVX2):#&:' \
+ configure.ac || die
+ fi
+
+ eautoreconf
+
+ sed -i \
+ -e 's:\(-ldl\):$(LDFLAGS) \1:' \
+ -e 's:\(-shared\):$(CFLAGS) $(LDFLAGS) \1:' \
+ Makefile || die
+}
+
+src_configure() {
+ use static && append-ldflags -static
+ # OpenSSL is only used by a random helper tool we don't install.
+ ac_cv_header_attr_xattr_h=$(usex xattr) \
+ ac_cv_header_openssl_evp_h=no \
+ ac_cv_lib_crypto_EVP_aes_192_ctr=no \
+ ac_cv_lib_lzo2_lzo1x_1_compress=$(usex lzo) \
+ ac_cv_header_lzo_lzo1x_h=$(usex lzo) \
+ econf
+}
+
+_emake() {
+ local arch
+ case ${ARCH} in
+ x86) arch=i386;;
+ amd64) arch=x86_64;;
+ arm) arch=arm;;
+ arm64) arch=aarch64;;
+ esac
+
+ local os=$(usex kernel_linux Linux IDK)
+
+ # The Makefile is a mess. Override a few vars rather than patch it.
+ emake \
+ MACH="${arch}" \
+ OS="${os}" \
+ HAVE_SSE42=$(usex cpu_flags_x86_sse4_2 1 0) \
+ HAVE_AVX2=$(usex cpu_flags_x86_avx2 1 0) \
+ RPM_OPT_FLAGS="${CFLAGS} ${CPPFLAGS}" \
+ CFLAGS_OPT='$(CFLAGS)' \
+ LDFLAGS="${LDFLAGS} -Wl,-rpath,${EPREFIX}/usr/$(get_libdir)/${PN}" \
+ CC="$(tc-getCC)" \
+ "$@"
+}
+
+src_compile() {
+ _emake
+}
+
+src_test() {
+ append-cflags -fcommon # bug 707796
+ _emake check
+}
+
+src_install() {
+ # easier to install by hand than trying to make sense of the Makefile.
+ dobin dd_rescue
+ dodir /usr/$(get_libdir)/${PN}
+ cp -pPR libddr_*.so "${ED}"/usr/$(get_libdir)/${PN}/ || die
+ dodoc README.dd_rescue
+ doman dd_rescue.1
+ use lzo && doman ddr_lzo.1
+}
diff --git a/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch b/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch
new file mode 100644
index 000000000000..d88649d65eae
--- /dev/null
+++ b/sys-fs/dd-rescue/files/dd-rescue-1.99.11-musl-r2.patch
@@ -0,0 +1,30 @@
+From 69c3974670f5a8ee0f2258f10a9228b39025b464 Mon Sep 17 00:00:00 2001
+From: Thomas Deutschmann <whissi@gentoo.org>
+Date: Wed, 13 Dec 2017 01:02:12 +0100
+Subject: [PATCH] loff_t and __WORDSIZE includes for MUSL
+
+Rewrite of Justin Keogh's patch [Link 1] to fix build problems
+on ARM.
+
+Link 1: https://gitweb.gentoo.org/repo/gentoo.git/commit/?id=5f5abc0f1b036921d6eb5b0f434c960ed280619f
+Fixes: https://bugs.gentoo.org/616364
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 7332da8..ef2016a 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -11,7 +11,7 @@ AC_C_INLINE
+
+ #AC_PROG_INSTALL
+ #CFLAGS="$CFLAGS -DHAVE_CONFIG_H"
+-AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h sys/xattr.h attr/xattr.h sys/acl.h sys/ioctl.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h sys/random.h malloc.h sched.h sys/statvfs.h sys/resource.h])
++AC_CHECK_HEADERS([fallocate.h dlfcn.h unistd.h sys/xattr.h attr/xattr.h sys/acl.h sys/ioctl.h sys/reg.h endian.h linux/fs.h linux/fiemap.h stdint.h lzo/lzo1x.h openssl/evp.h linux/random.h sys/random.h malloc.h sched.h sys/statvfs.h sys/resource.h])
+ AC_CHECK_FUNCS([ffs ffsl basename fallocate64 splice getopt_long open64 pread pread64 lseek64 stat64 posix_fadvise posix_fadvise64 __builtin_prefetch htobe64 feof_unlocked getline getentropy getrandom posix_memalign valloc sched_yield fstatvfs __builtin_cpu_supports getrlimit aligned_alloc])
+ AC_CHECK_LIB(dl,dlsym)
+ AC_CHECK_LIB(fallocate,linux_fallocate64)
+--
+2.31.1
+