summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2024-01-22 17:41:56 +0100
committerDavid Seifert <soap@gentoo.org>2024-01-22 17:41:56 +0100
commit1f1a6e3f717b0518889a6f508455389b19860e48 (patch)
tree3f44643d1eabee73e16efd9f4aadf156e9975df5 /sys-fs
parentnet-dns/c-ares: Stabilize 1.25.0-r1 arm, #922706 (diff)
downloadgentoo-1f1a6e3f717b0518889a6f508455389b19860e48.tar.gz
gentoo-1f1a6e3f717b0518889a6f508455389b19860e48.tar.bz2
gentoo-1f1a6e3f717b0518889a6f508455389b19860e48.zip
sys-fs/hfsplusutils: Fix `-Wincompatible-pointer-types`
Closes: https://bugs.gentoo.org/919483 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-Wincompatible-pointer-types.patch32
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild3
2 files changed, 34 insertions, 1 deletions
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-Wincompatible-pointer-types.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-Wincompatible-pointer-types.patch
new file mode 100644
index 000000000000..0ad76d93f453
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-Wincompatible-pointer-types.patch
@@ -0,0 +1,32 @@
+--- a/src/charset.c
++++ b/src/charset.c
+@@ -159,7 +159,7 @@
+ * NAME: charset->latin1()
+ * DESCRIPTION: return a Latin-1 (ISO 8859-1) string for MacOS Standard Roman
+ */
+-char *cs_latin1(char *mstr, int *lenptr)
++char *cs_latin1(char *mstr, size_t *lenptr)
+ {
+ int ilen, olen, i;
+ char *latin1, *ptr;
+--- a/src/charset.h
++++ b/src/charset.h
+@@ -23,6 +23,9 @@
+ *
+ * $Id: charset.h,v 1.1.1.1 2002/03/05 19:50:29 klaus Exp $
+ */
++
++#include <stddef.h>
++
+ /* a two byte unicode character, gnus wchar_t is 4 bytes in linux */
+ typedef unsigned short UCS2;
+
+@@ -35,7 +38,7 @@
+ * lenptr may be null in wich case the given strs len is used.
+ * on return *lenptr is set to the returned strings len.
+ * must be free()d */
+-char *cs_latin1(char *, int *);
++char *cs_latin1(char *, size_t *);
+
+ /* return a MacOS Standard Roman string for Latin-1 (ISO 8859-1).
+ * lenptr may be null in wich case the given strs len is used.
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild
index e27b2512b24c..203f0abf002b 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r3.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}"/${P}-cflags.patch
"${FILESDIR}"/${P}-fno-common-gcc10.patch
"${FILESDIR}"/${P}-gcc5.patch
+ "${FILESDIR}"/${P}-Wincompatible-pointer-types.patch
)
src_prepare() {