summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorFlorian Schmaus <flow@gentoo.org>2023-09-21 11:03:26 +0200
committerFlorian Schmaus <flow@gentoo.org>2023-09-21 11:03:26 +0200
commit20db84ae6841a0bf865758d870c8fb47a3aaccf4 (patch)
tree0dce603d4f2ce936b7baeea492146795d1910ef8 /sys-fs
parentsys-fs/bcache-tools: use upstream's 'install' target (diff)
downloadgentoo-20db84ae6841a0bf865758d870c8fb47a3aaccf4.tar.gz
gentoo-20db84ae6841a0bf865758d870c8fb47a3aaccf4.tar.bz2
gentoo-20db84ae6841a0bf865758d870c8fb47a3aaccf4.zip
sys-fs/bcache-tools: sync live
Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bcache-tools/bcache-tools-9999.ebuild32
1 files changed, 18 insertions, 14 deletions
diff --git a/sys-fs/bcache-tools/bcache-tools-9999.ebuild b/sys-fs/bcache-tools/bcache-tools-9999.ebuild
index 48838cb95962..baefd75f9838 100644
--- a/sys-fs/bcache-tools/bcache-tools-9999.ebuild
+++ b/sys-fs/bcache-tools/bcache-tools-9999.ebuild
@@ -37,29 +37,33 @@ src_prepare() {
sed \
-e '/^CFLAGS/s:-O2::' \
-e '/^CFLAGS/s:-g::' \
+ -e '/.*INSTALL.*share\/man/d' \
+ -e '/.*INSTALL.*bcache-status/d' \
-i Makefile || die
append-lfs-flags
}
src_install() {
- into /
- dosbin bcache make-bcache bcache-super-show
-
- exeinto $(get_udevdir)
- doexe bcache-register probe-bcache bcache-export-cached
+ local udevdir="$(get_udevdir)"
+
+ local mydirs=(
+ sbin
+ "${udevdir}/rules.d"
+ /usr/share/initramfs-tools/hooks/bcache
+ /usr/lib/initcpio/install/bcache
+ )
+ dodir "${mydirs[@]}"
+
+ emake \
+ DESTDIR="${D}" \
+ PREFIX="${EPREFIX}" \
+ UDEVLIBDIR="${udevdir}" \
+ DRACUTLIBDIR="/usr/lib/dracut" \
+ install
python_foreach_impl python_doscript bcache-status
- udev_dorules 69-bcache.rules
-
- insinto /etc/initramfs-tools/hooks/bcache
- doins initramfs/hook
-
- # that is what dracut does
- insinto /usr/lib/dracut/modules.d/90bcache
- doins dracut/module-setup.sh
-
doman *.8
dodoc README