summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-02-08 13:06:45 +0100
committerDavid Seifert <soap@gentoo.org>2020-02-08 13:06:45 +0100
commit2a279e72974f0b853750e1c11fe5449a0a032660 (patch)
tree567aaca21651c10742aa7679d12541e32d4867f3 /sys-fs
parentapp-shells/zsh-syntax-highlighting: Initial commit (diff)
downloadgentoo-2a279e72974f0b853750e1c11fe5449a0a032660.tar.gz
gentoo-2a279e72974f0b853750e1c11fe5449a0a032660.tar.bz2
gentoo-2a279e72974f0b853750e1c11fe5449a0a032660.zip
sys-fs/hfsplusutils: Fix GCC 10
Closes: https://bugs.gentoo.org/707690 Package-Manager: Portage-2.3.87, Repoman-2.3.20 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch27
-rw-r--r--sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild3
2 files changed, 29 insertions, 1 deletions
diff --git a/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch
new file mode 100644
index 000000000000..dde912d4ef62
--- /dev/null
+++ b/sys-fs/hfsplusutils/files/hfsplusutils-1.0.4-fno-common-gcc10.patch
@@ -0,0 +1,27 @@
+--- a/libhfsp/src/fscheck.c
++++ b/libhfsp/src/fscheck.c
+@@ -47,6 +47,8 @@
+ # include "os.h"
+ # include "swab.h"
+
++struct fsck_data_t fsck_data;
++
+ /* Dump all raw fork information to stdout */
+ void print_fork(hfsp_fork_raw* f)
+ {
+--- a/libhfsp/src/fscheck.h
++++ b/libhfsp/src/fscheck.h
+@@ -100,10 +100,11 @@
+ int fscheck_files(volume* vol);
+
+ /** global data used during fsck */
+-struct {
++struct fsck_data_t {
+ UInt32 maxCnid;
+ UInt32 macNow; // current date in mac-offset
+ int verbose;
+ int ignoreErr;
+-} fsck_data;
++};
+
++extern struct fsck_data_t fsck_data;
diff --git a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
index 4e624f1b33c8..a578df335018 100644
--- a/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
+++ b/sys-fs/hfsplusutils/hfsplusutils-1.0.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -24,6 +24,7 @@ PATCHES=(
"${FILESDIR}"/${P}-string.patch
"${FILESDIR}"/${P}-stdlib.patch
"${FILESDIR}"/${P}-cflags.patch
+ "${FILESDIR}"/${P}-fno-common-gcc10.patch
)
src_prepare() {