summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorWANG Xuerui <xen0n@gentoo.org>2022-08-12 21:01:37 +0800
committerWANG Xuerui <xen0n@gentoo.org>2022-08-12 21:01:37 +0800
commit2faa0187750d0c558fc59668a58e6fb4cab5c6b2 (patch)
tree514136d4048b0f7d12ecea94d208ac7574b8f6f9 /sys-fs
parentnet-wireless/qdmr: x86 stable wrt bug #861038 (diff)
downloadgentoo-2faa0187750d0c558fc59668a58e6fb4cab5c6b2.tar.gz
gentoo-2faa0187750d0c558fc59668a58e6fb4cab5c6b2.tar.bz2
gentoo-2faa0187750d0c558fc59668a58e6fb4cab5c6b2.zip
sys-fs/erofs-utils: add 1.5
Signed-off-by: WANG Xuerui <xen0n@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/erofs-utils/Manifest1
-rw-r--r--sys-fs/erofs-utils/erofs-utils-1.5.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/sys-fs/erofs-utils/Manifest b/sys-fs/erofs-utils/Manifest
index 0c2d2532e5de..560349e50cf2 100644
--- a/sys-fs/erofs-utils/Manifest
+++ b/sys-fs/erofs-utils/Manifest
@@ -1 +1,2 @@
DIST erofs-utils-1.4.tar.gz 93979 BLAKE2B aef1dca8cb95e6104d73a84590319d3c55aba1a4ef5dbdbf470662cb86ee1b66a5707dc1c453470115ec6f2bf1246ee4b6b28aa1cb83b4cb9c8eed45e88668d4 SHA512 ab95d6a7b2d278ee443d1e378c62354db66ce7ab5ce03b3a8d9004cf498c4e43e3e8ced6524444d2ea4871c4db0195489f033180c8a2082c2cba69c46c09692f
+DIST erofs-utils-1.5.tar.gz 106559 BLAKE2B 69a2b93c0ba8c50fb3f75a53cc224490ab31f55e24055932091e85032a637c2be6d937ab42f068a2937e5b9d8b6054fd756e89b9333f47a6b6b35c20a421ed49 SHA512 0a9d593a9fef3c5976dc63e2927f47d070121ed07e6dda727b0a715b72cfe560c83bdf26ce41fe07b8cb5b66b0660105848e3f7c5a84f222296eb422d1cd5cba
diff --git a/sys-fs/erofs-utils/erofs-utils-1.5.ebuild b/sys-fs/erofs-utils/erofs-utils-1.5.ebuild
new file mode 100644
index 000000000000..6ad7945f7521
--- /dev/null
+++ b/sys-fs/erofs-utils/erofs-utils-1.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="Userspace tools for EROFS"
+HOMEPAGE="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/erofs-utils.git"
+LICENSE="GPL-2+"
+
+SRC_URI="https://git.kernel.org/pub/scm/linux/kernel/git/xiang/${PN}.git/snapshot/${P}.tar.gz"
+KEYWORDS="~amd64 ~loong"
+
+SLOT="0"
+IUSE="fuse +lz4 selinux +uuid"
+
+RDEPEND="
+ fuse? ( sys-fs/fuse:0 )
+ lz4? ( app-arch/lz4:0= )
+ selinux? ( sys-libs/libselinux:0= )
+ uuid? ( sys-apps/util-linux )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # This package asks for MicroLZMA support, which is not included in any
+ # released version of xz-utils at the moment, so disable lzma until a new
+ # xz-utils is packaged.
+ econf \
+ --disable-werror \
+ $(use_enable fuse) \
+ $(use_enable lz4) \
+ --disable-lzma \
+ $(use_with selinux) \
+ $(use_with uuid)
+}