summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2024-02-19 14:31:21 -0800
committerRobin H. Johnson <robbat2@gentoo.org>2024-02-19 14:31:52 -0800
commit472cbf6119a834698effe44ed3d00f1c6109aecf (patch)
treee668e18ab55e4904387dffd838e4332f0d11d49e /sys-fs
parentapp-emacs/citeproc-el: Stabilize 0.9.4-r1 amd64, #925008 (diff)
downloadgentoo-472cbf6119a834698effe44ed3d00f1c6109aecf.tar.gz
gentoo-472cbf6119a834698effe44ed3d00f1c6109aecf.tar.bz2
gentoo-472cbf6119a834698effe44ed3d00f1c6109aecf.zip
sys-fs/mdadm: cleanup
Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mdadm/Manifest2
-rw-r--r--sys-fs/mdadm/mdadm-4.1.ebuild94
2 files changed, 0 insertions, 96 deletions
diff --git a/sys-fs/mdadm/Manifest b/sys-fs/mdadm/Manifest
index d352735ae923..961f422d5fb6 100644
--- a/sys-fs/mdadm/Manifest
+++ b/sys-fs/mdadm/Manifest
@@ -1,4 +1,2 @@
-DIST mdadm-4.1.tar.xz 440756 BLAKE2B df0506d937c2aa309d7c68804f66f7dcd51783288594bf746832311c64b8cf82004af4af5f246c5f9753f1de324ff7d49b5ee752d6a00ec03864f7885389706e SHA512 0859c5d3e786345d93ff2c3b291ca8866ba60f1375479e5b4d343124f6824140a8268d42b8ae603b069edba761aa30aaf20d49e9ec54dfcbad34bad3bea0e433
DIST mdadm-4.2.tar.xz 453624 BLAKE2B de7c4318dc5479de41378233869ab84ca2cd0e8a42310157b1acb969e7152af61556fbbe6f17bf6af4dfaf5543e49b1c982d2baeedf1c39b000032f4db7f5502 SHA512 57897a2b7fb8b0b88bece50501099872bb45ddb076cfc323d563588096d2b66b1ecba3724534943f651ace2bfe591482570700616500dc3398552e4f9ff0c37d
-DIST mdadm_4.1-3.debian.tar.xz 89640 BLAKE2B 3cb5e42dcbd218a71e55127cecda6f2594a1b1691e17c05f52a8cd0ba05b556d2812772e53d78de025738d7c2de059df3f878b8290ba3906b3d75ef435bfb698 SHA512 e9b04abf195d7bda9fb0197eb926c01a69b879ef82c72af6497116cea9be8f0823408dddbe5c6c033f5fae554a8fec17299e361fa48045e033c87dcee1a0bb63
DIST mdadm_4.2~rc2-7.debian.tar.xz 89904 BLAKE2B dd04f2dd044d0bca85920eaf5c79a288d69c47a7ad7e36509a126c01ef63bd045d7e0530450650028de39d74ad852995ca080c3a73dbcb1cf1b3783118109f35 SHA512 3d36533d2713b663606919b2bfec18b15e18a6a0194e333e38e4a58f175da96af7b1fe16f0c36ee148e14492a4e0710b9fad6ac7856495b63c0176ebb7333be6
diff --git a/sys-fs/mdadm/mdadm-4.1.ebuild b/sys-fs/mdadm/mdadm-4.1.ebuild
deleted file mode 100644
index 21649c23547f..000000000000
--- a/sys-fs/mdadm/mdadm-4.1.ebuild
+++ /dev/null
@@ -1,94 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-inherit flag-o-matic multilib systemd toolchain-funcs udev
-
-DESCRIPTION="Tool for running RAID systems - replacement for the raidtools"
-HOMEPAGE="https://git.kernel.org/pub/scm/utils/mdadm/mdadm.git/"
-DEB_PF="4.1-3"
-SRC_URI="https://www.kernel.org/pub/linux/utils/raid/mdadm/${P/_/-}.tar.xz
- mirror://debian/pool/main/m/mdadm/${PN}_${DEB_PF}.debian.tar.xz"
-
-LICENSE="GPL-2"
-SLOT="0"
-[[ "${PV}" = *_rc* ]] || \
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="static"
-
-BDEPEND="virtual/pkgconfig
- app-arch/xz-utils"
-RDEPEND=">=sys-apps/util-linux-2.16"
-DEPEND="${RDEPEND}"
-
-# The tests edit values in /proc and run tests on software raid devices.
-# Thus, they shouldn't be run on systems with active software RAID devices.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-3.4-sysmacros.patch #580188
-)
-
-mdadm_emake() {
- # We should probably make corosync & libdlm into USE flags. #573782
- local args=(
- PKG_CONFIG="$(tc-getPKG_CONFIG)"
- CC="$(tc-getCC)"
- CWFLAGS="-Wall"
- CXFLAGS="${CFLAGS}"
- UDEVDIR="$(get_udevdir)"
- SYSTEMD_DIR="$(systemd_get_systemunitdir)"
- COROSYNC="-DNO_COROSYNC"
- DLM="-DNO_DLM"
-
- # https://bugs.gentoo.org/732276
- STRIP=
-
- "$@"
- )
- emake "${args[@]}"
-}
-
-src_compile() {
- use static && append-ldflags -static
- mdadm_emake all
-}
-
-src_test() {
- mdadm_emake test
-
- sh ./test || die
-}
-
-src_install() {
- mdadm_emake DESTDIR="${D}" install install-systemd
- dodoc ChangeLog INSTALL TODO README* ANNOUNCE-*
-
- insinto /etc
- newins mdadm.conf-example mdadm.conf
- newinitd "${FILESDIR}"/mdadm.rc mdadm
- newconfd "${FILESDIR}"/mdadm.confd mdadm
- newinitd "${FILESDIR}"/mdraid.rc mdraid
- newconfd "${FILESDIR}"/mdraid.confd mdraid
-
- # From the Debian patchset
- into /usr
- dodoc "${WORKDIR}"/debian/README.checkarray
- dosbin "${WORKDIR}"/debian/checkarray
- insinto /etc/default
- newins "${FILESDIR}"/etc-default-mdadm mdadm
-
- exeinto /etc/cron.weekly
- newexe "${FILESDIR}"/mdadm.weekly mdadm
-}
-
-pkg_postinst() {
- if ! systemd_is_booted; then
- if [[ -z ${REPLACING_VERSIONS} ]] ; then
- # Only inform people the first time they install.
- elog "If you're not relying on kernel auto-detect of your RAID"
- elog "devices, you need to add 'mdraid' to your 'boot' runlevel:"
- elog " rc-update add mdraid boot"
- fi
- fi
-}