summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2020-03-31 13:36:52 -0700
committerMatt Turner <mattst88@gentoo.org>2020-03-31 13:44:02 -0700
commit4ed11e592c4c57a2c5c18159b9dff734df5495e7 (patch)
tree6386366be80aef4a3f54e686a65164e44d99cac6 /sys-fs
parentmedia-libs/waffle: Version bump to 1.6.1 (diff)
downloadgentoo-4ed11e592c4c57a2c5c18159b9dff734df5495e7.tar.gz
gentoo-4ed11e592c4c57a2c5c18159b9dff734df5495e7.tar.bz2
gentoo-4ed11e592c4c57a2c5c18159b9dff734df5495e7.zip
sys-fs/squashfs-tools-ng: Version bump to 0.9
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools-ng/Manifest1
-rw-r--r--sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools-ng/Manifest b/sys-fs/squashfs-tools-ng/Manifest
index 9ec65d75dbfe..2ad1b501280f 100644
--- a/sys-fs/squashfs-tools-ng/Manifest
+++ b/sys-fs/squashfs-tools-ng/Manifest
@@ -1,2 +1,3 @@
DIST squashfs-tools-ng-0.7.tar.xz 372956 BLAKE2B 5fd0849c8cb0255ea56edc5b5cdc771363f5ca038f4306bb7d816ff26ce23cbd4f4652ef8ae497b8c9fe1ec09f9ebcfcf13aeb6b99b97db80a95018c25d4a3a6 SHA512 e53d7b64e68a40b49667b65d9fa8f12e977e8ca923c2fe9ce1e1def2745573f8607f7dee7ae6c06496489ef721c4c500ec40513ea5f6bd3ad4bb3a7796972b8e
DIST squashfs-tools-ng-0.8.tar.xz 1004616 BLAKE2B 5d347eef252886e7750da306f038494a15660350aca7b93aaf85a8411882489d8855c771e719a68b025f5c15fdc8b0d30727dde0884c5982460ff85d106fcd37 SHA512 7a533c7f9f21f717718a9ce5d775cf297c2e8edb6f121741b14692b52cbb6e3d7fe5cd59525222f7f9617440ea2adb2acec4dda3252abf3bebc689905b9fdc20
+DIST squashfs-tools-ng-0.9.tar.xz 1020728 BLAKE2B 4f6672aecfa1f664198465154ad1d1ba92f741bcad576f90b58cdc982cc8a20d21dc7cfcb825604e2801ce187d5f984d55131c04859de0d7e67f515cddd781ac SHA512 6394cb851828f110ed6a3ab17923b214b79b8bb5550069407839da62e5316459d7f564cb31211c849508b9664f4f1f9030ce5f64d5c8649b8a73c3a869ab22d0
diff --git a/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild
new file mode 100644
index 000000000000..79c567828ddc
--- /dev/null
+++ b/sys-fs/squashfs-tools-ng/squashfs-tools-ng-0.9.ebuild
@@ -0,0 +1,51 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A new set of tools for working with SquashFS images"
+HOMEPAGE="https://github.com/AgentD/squashfs-tools-ng"
+if [[ ${PV} = 9999* ]]; then
+ inherit autotools git-r3
+ EGIT_REPO_URI="https://github.com/AgentD/${PN}.git"
+else
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+ SRC_URI="https://infraroot.at/pub/squashfs/${P}.tar.xz"
+fi
+
+LICENSE="LGPL-3+ tools? ( GPL-3+ )"
+SLOT="0"
+IUSE="lz4 lzo selinux +tools +xz zstd"
+
+DEPEND="
+ sys-libs/zlib:=
+ lz4? ( app-arch/lz4:= )
+ lzo? ( dev-libs/lzo:= )
+ xz? ( app-arch/xz-utils:= )
+ selinux? ( sys-libs/libselinux:= )
+ zstd? ( app-arch/zstd:= )
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == "9999" ]] && eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --disable-static
+ $(use_with lz4)
+ $(use_with lzo)
+ $(use_with selinux)
+ $(use_with tools)
+ $(use_with xz)
+ $(use_with zstd)
+ )
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}