summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-05-25 21:14:57 +0200
committerSebastian Pipping <sping@gentoo.org>2022-05-25 21:17:15 +0200
commit572e04698f80f0caaaeb55719282d859f46be93d (patch)
tree93e2f0282a7796ab2faa0258ce5526cb7ffb659c /sys-fs
parentnet-misc/gallery-dl: drop old 1.21.0 (diff)
downloadgentoo-572e04698f80f0caaaeb55719282d859f46be93d.tar.gz
gentoo-572e04698f80f0caaaeb55719282d859f46be93d.tar.bz2
gentoo-572e04698f80f0caaaeb55719282d859f46be93d.zip
sys-fs/unionfs-fuse: Python 3.10 + EAPI 8
Closes: https://bugs.gentoo.org/846329 Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.30, Repoman-3.0.3
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild47
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild6
2 files changed, 50 insertions, 3 deletions
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild
new file mode 100644
index 000000000000..2312fa71e7c0
--- /dev/null
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.2-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit python-any-r1 toolchain-funcs
+
+DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
+HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
+SRC_URI="https://github.com/rpodgorny/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="sys-fs/fuse:0"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )
+"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+python_check_deps() {
+ use test || return 0
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+src_compile() {
+ emake AR="$(tc-getAR)" CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+}
+
+src_test() {
+ [[ -e /dev/fuse ]] || return 0
+ addwrite /dev/fuse
+ pytest -vv || die "Tests fail with ${EPYTHON}"
+}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index 5897a40f2915..eab277c33f84 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="7"
+EAPI="8"
-PYTHON_COMPAT=( python3_{7..9} )
+PYTHON_COMPAT=( python3_{8..10} )
inherit git-r3 python-any-r1 toolchain-funcs
DESCRIPTION="Self-syncing tree-merging file system based on FUSE"