summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2017-08-27 22:25:10 +0200
committerSebastian Pipping <sping@gentoo.org>2017-08-27 22:55:33 +0200
commit5ab62e16b8464ee92590bb9d32a52b91088b67b2 (patch)
tree788fffae6bfd4457fc52750400293e0119935d31 /sys-fs
parentwww-servers/gatling: 0.15 (diff)
downloadgentoo-5ab62e16b8464ee92590bb9d32a52b91088b67b2.tar.gz
gentoo-5ab62e16b8464ee92590bb9d32a52b91088b67b2.tar.bz2
gentoo-5ab62e16b8464ee92590bb9d32a52b91088b67b2.zip
sys-fs/unionfs-fuse: 2.0
Also sync live ebuild Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/unionfs-fuse/Manifest1
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-2.0.ebuild21
-rw-r--r--sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild4
3 files changed, 24 insertions, 2 deletions
diff --git a/sys-fs/unionfs-fuse/Manifest b/sys-fs/unionfs-fuse/Manifest
index 60c4fc83aab6..fa4bcda6e133 100644
--- a/sys-fs/unionfs-fuse/Manifest
+++ b/sys-fs/unionfs-fuse/Manifest
@@ -1 +1,2 @@
DIST unionfs-fuse-1.0.tar.gz 48149 SHA256 2ee80bd0634a61adb2159212e155d607a0a82ad659214ae6edb3530396cccc09 SHA512 805151acaeae8526fba430701a1690f6eb0ad8331a9e730095ee538dc2b148d02fe996a63e8a7f6471d1ef622cc5c03d82bd2b2faad1ebe3b614ec343c2f55de WHIRLPOOL 447c8ef93c26f33ba3e8d4ee6bbc48ae545f4cda2e66a832e78ec750ceaa3428546f98cfda8a64eafd78aec2c567e21e1121ef49a2e967b67b23ecf725807449
+DIST unionfs-fuse-2.0.tar.gz 46537 SHA256 f24d7dd64c678cefacbebf2727b61e3127b8ecb6bb9176d7117dd31503455643 SHA512 5b60204632f498931fff7671cc9f40b1800d34cb8c0d0de0773626e2653eb0a36647566c92c1d0cf79543e01b934602ef5603a06508407f352e48ef27a7ee758 WHIRLPOOL c5a25a69bdb5285ede5be21f1723b84779d5b80893b07de1d264b1da7c663450ed1ff1472b06ff4b5b103d14fc1c8a9a70a75d0c04d98a97cf7596683a527c80
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-2.0.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-2.0.ebuild
new file mode 100644
index 000000000000..16259309343f
--- /dev/null
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-2.0.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+DESCRIPTION="Self-syncing tree-merging file system based on FUSE"
+
+HOMEPAGE="https://github.com/rpodgorny/unionfs-fuse"
+SRC_URI="https://github.com/rpodgorny/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+IUSE=""
+
+DEPEND="sys-fs/fuse"
+RDEPEND="${DEPEND}"
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install || die "emake install failed"
+}
diff --git a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
index 7c8ce5e599e9..24a0355898f4 100644
--- a/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
+++ b/sys-fs/unionfs-fuse/unionfs-fuse-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI="5"
+EAPI="6"
inherit git-r3