summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-07 06:55:27 +0000
committerSam James <sam@gentoo.org>2021-12-07 06:56:52 +0000
commit5d2b69ad3b74a4b44b160e8ac93c8d6fa426624d (patch)
tree0825994ce1463a5c91e2a024c01a73d88f1cffa9 /sys-fs
parentmedia-libs/hamlib: Drop old (diff)
downloadgentoo-5d2b69ad3b74a4b44b160e8ac93c8d6fa426624d.tar.gz
gentoo-5d2b69ad3b74a4b44b160e8ac93c8d6fa426624d.tar.bz2
gentoo-5d2b69ad3b74a4b44b160e8ac93c8d6fa426624d.zip
sys-fs/encfs: install libencfs, link dynamically
We need to install libencfs if we're going to link dynamically against it. Closes: https://bugs.gentoo.org/701698 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/encfs/encfs-1.9.5-r2.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/encfs/encfs-1.9.5-r2.ebuild b/sys-fs/encfs/encfs-1.9.5-r2.ebuild
new file mode 100644
index 000000000000..c26268474a9d
--- /dev/null
+++ b/sys-fs/encfs/encfs-1.9.5-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="An implementation of encrypted filesystem in user-space using FUSE"
+HOMEPAGE="https://vgough.github.io/encfs/"
+SRC_URI="https://github.com/vgough/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3 LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc64 ~sparc ~x86"
+IUSE="nls"
+
+RDEPEND="dev-libs/openssl:=
+ dev-libs/tinyxml2:=
+ sys-fs/fuse:0=
+ sys-libs/zlib"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-lang/perl
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+# Build dir is hardcoded in test suite, but we restrict them
+# because they can lead to false negatives, bug #630486
+RESTRICT="test"
+
+BUILD_DIR="${S}/build"
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_NLS="$(usex nls)"
+ -DUSE_INTERNAL_TINYXML=OFF
+ -DBUILD_UNIT_TESTS=OFF
+ -DBUILD_SHARED_LIBS=ON
+ # Needed with BUILD_SHARED_LIBS=ON
+ -DINSTALL_LIBENCFS=ON
+ -DLIB_INSTALL_DIR="$(get_libdir)"
+ )
+ cmake_src_configure
+}