summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorKai Krakow <kai@kaishome.de>2019-11-28 22:33:53 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-11-30 09:48:55 +0200
commit5edfb351c0192a34bbbbacd38a9c7fb7de1cf26d (patch)
tree2883e239ff69e93658d603943a3e322b34717af8 /sys-fs
parentsys-fs/bees: Adjust -9999 for current upstream changes (diff)
downloadgentoo-5edfb351c0192a34bbbbacd38a9c7fb7de1cf26d.tar.gz
gentoo-5edfb351c0192a34bbbbacd38a9c7fb7de1cf26d.tar.bz2
gentoo-5edfb351c0192a34bbbbacd38a9c7fb7de1cf26d.zip
sys-fs/bees: Bump to v0.6.1-r2
Closes: https://bugs.gentoo.org/701422 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Kai Krakow <kai@kaishome.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/bees-0.6.1-r2.ebuild98
-rw-r--r--sys-fs/bees/files/6003-process-Fix-gettid-ambiguity-with-glibc-2.30.patch97
2 files changed, 195 insertions, 0 deletions
diff --git a/sys-fs/bees/bees-0.6.1-r2.ebuild b/sys-fs/bees/bees-0.6.1-r2.ebuild
new file mode 100644
index 000000000000..38c83939e49a
--- /dev/null
+++ b/sys-fs/bees/bees-0.6.1-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
+HOMEPAGE="https://github.com/Zygo/bees"
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Zygo/bees.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="tools"
+
+DEPEND="
+ >=sys-apps/util-linux-2.30.2
+ >=sys-fs/btrfs-progs-4.20.2
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~BTRFS_FS"
+ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
+
+PATCHES=(
+ "${FILESDIR}/6001-lib-fix-non-local-lambda-expression-cannot-have-a-ca.patch"
+ "${FILESDIR}/6002-context-workaround-to-prevent-LOGICAL_INO-and-btrfs-.patch"
+ "${FILESDIR}/6003-process-Fix-gettid-ambiguity-with-glibc-2.30.patch"
+)
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if kernel_is -lt 4 4 3; then
+ ewarn "Kernel versions below 4.4.3 lack critical features needed for bees to"
+ ewarn "properly operate, so it won't work. It's recommended to run at least"
+ ewarn "kernel version 4.11 for best performance and reliability."
+ ewarn
+ elif kernel_is -lt 4 11; then
+ ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
+ ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
+ ewarn "running, it's recommended to run at least kernel 4.11."
+ ewarn
+ elif kernel_is -lt 4 14 29; then
+ ewarn "With kernel versions below 4.14.29, bees may generate a lot of bogus WARN_ON()"
+ ewarn "messages in the kernel log. These messages can be ignored and this is fixed"
+ ewarn "with more recent kernels:"
+ ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
+ ewarn
+ fi
+
+ if kernel_is -lt 5 3 4; then
+ ewarn "With kernel versions below 5.3.4, bees may trigger a btrfs bug when running"
+ ewarn "btrfs-balance in parallel. This may lead to meta-data corruption in the worst"
+ ewarn "case. Especially, kernels 5.1.21 and 5.2.21 should be avoided. Kernels 5.0.x"
+ ewarn "after 5.0.21 should be safe. In the best case, affected kernels may force"
+ ewarn "the device RO without writing corrupted meta-data. More details:"
+ ewarn "https://github.com/Zygo/bees/blob/master/docs/btrfs-kernel.md"
+ ewarn
+ fi
+
+ if kernel_is -lt 5 0 4; then
+ ewarn "IMPORTANT: With kernel versions below 5.0.4, you may experience data corruption"
+ ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
+ ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
+ ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
+ ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
+ ewarn
+ fi
+
+ elog "Bees recommends running the latest current kernel for performance and"
+ elog "reliability reasons, see README.md."
+ fi
+}
+
+src_configure() {
+ cat >localconf <<-EOF || die
+ LIBEXEC_PREFIX=/usr/libexec
+ PREFIX=/usr
+ LIBDIR="$(get_libdir)"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+ DEFAULT_MAKE_TARGET=all
+ EOF
+ if [[ ${PV} != "9999" ]] ; then
+ cat >>localconf <<-EOF || die
+ BEES_VERSION=v${PV}
+ EOF
+ fi
+ if use tools; then
+ echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
+ fi
+}
diff --git a/sys-fs/bees/files/6003-process-Fix-gettid-ambiguity-with-glibc-2.30.patch b/sys-fs/bees/files/6003-process-Fix-gettid-ambiguity-with-glibc-2.30.patch
new file mode 100644
index 000000000000..9f53e5b37da3
--- /dev/null
+++ b/sys-fs/bees/files/6003-process-Fix-gettid-ambiguity-with-glibc-2.30.patch
@@ -0,0 +1,97 @@
+From 0b7cf9c0f11722c7cb8a816e9118602b43d9a3f5 Mon Sep 17 00:00:00 2001
+From: Zygo Blaxell <bees@furryterror.org>
+Date: Tue, 29 Oct 2019 23:34:36 -0400
+Subject: [PATCH 3/3] process: Fix gettid() ambiguity with glibc >= 2.30
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+In version 2.30 glibc added it's own gettid() function. This resulted in
+"error: call of overloaded ‘gettid()’ is ambiguous" because gettid()
+now exists in both namespace crucible and std.
+
+For now, use explicit references to namespace crucible. This continues
+to work with new and old libc without having to test specific library
+versions.
+
+At some point, glibc gettid() will be deployed widely enough that we can
+remove the crucible version entirely.
+
+Signed-off-by: Zygo Blaxell <bees@furryterror.org>
+---
+ include/crucible/lockset.h | 4 ++--
+ lib/chatter.cc | 4 ++--
+ src/bees.cc | 6 +++---
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/include/crucible/lockset.h b/include/crucible/lockset.h
+index 856c55e..99500b7 100644
+--- a/include/crucible/lockset.h
++++ b/include/crucible/lockset.h
+@@ -117,7 +117,7 @@ namespace crucible {
+ while (full() || locked(name)) {
+ m_condvar.wait(lock);
+ }
+- auto rv = m_set.insert(make_pair(name, gettid()));
++ auto rv = m_set.insert(make_pair(name, crucible::gettid()));
+ THROW_CHECK0(runtime_error, rv.second);
+ }
+
+@@ -129,7 +129,7 @@ namespace crucible {
+ if (full() || locked(name)) {
+ return false;
+ }
+- auto rv = m_set.insert(make_pair(name, gettid()));
++ auto rv = m_set.insert(make_pair(name, crucible::gettid()));
+ THROW_CHECK1(runtime_error, name, rv.second);
+ return true;
+ }
+diff --git a/lib/chatter.cc b/lib/chatter.cc
+index cbd5adb..e5a24f9 100644
+--- a/lib/chatter.cc
++++ b/lib/chatter.cc
+@@ -69,14 +69,14 @@ namespace crucible {
+ DIE_IF_ZERO(strftime(buf, sizeof(buf), "%Y-%m-%d %H:%M:%S", &ltm));
+
+ header_stream << buf;
+- header_stream << " " << getpid() << "." << gettid() << "<" << m_loglevel << ">";
++ header_stream << " " << getpid() << "." << crucible::gettid() << "<" << m_loglevel << ">";
+ if (!m_name.empty()) {
+ header_stream << " " << m_name;
+ }
+ } else {
+ header_stream << "<" << m_loglevel << ">";
+ header_stream << (m_name.empty() ? "thread" : m_name);
+- header_stream << "[" << gettid() << "]";
++ header_stream << "[" << crucible::gettid() << "]";
+ }
+
+ header_stream << ": ";
+diff --git a/src/bees.cc b/src/bees.cc
+index 08c3fd7..aa55af0 100644
+--- a/src/bees.cc
++++ b/src/bees.cc
+@@ -115,9 +115,9 @@ BeesNote::~BeesNote()
+ tl_next = m_prev;
+ unique_lock<mutex> lock(s_mutex);
+ if (tl_next) {
+- s_status[gettid()] = tl_next;
++ s_status[crucible::gettid()] = tl_next;
+ } else {
+- s_status.erase(gettid());
++ s_status.erase(crucible::gettid());
+ }
+ }
+
+@@ -128,7 +128,7 @@ BeesNote::BeesNote(function<void(ostream &os)> f) :
+ m_prev = tl_next;
+ tl_next = this;
+ unique_lock<mutex> lock(s_mutex);
+- s_status[gettid()] = tl_next;
++ s_status[crucible::gettid()] = tl_next;
+ }
+
+ void
+--
+2.23.0
+