summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 13:53:07 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-09-16 13:53:47 +0200
commit610af1a698ac2ca712034ff1928d56b51b61458c (patch)
treed7a70899e2621b420c8cd97b580c6d998fbc3a57 /sys-fs
parentprofiles: Mask Qt5-based sci-geosciences/qgis-2.18.12-r100 (diff)
downloadgentoo-610af1a698ac2ca712034ff1928d56b51b61458c.tar.gz
gentoo-610af1a698ac2ca712034ff1928d56b51b61458c.tar.bz2
gentoo-610af1a698ac2ca712034ff1928d56b51b61458c.zip
sys-fs/quota: Fix build with glibc-2.26 and libtirpc.
Revbump since I'm not 100% sure about side effects if in previous glibc+libtirpc combinations duplicate headers were installed. Package-Manager: Portage-2.3.8, Repoman-2.3.3
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/files/quota-4.04-glibc226.patch43
-rw-r--r--sys-fs/quota/quota-4.04-r1.ebuild83
2 files changed, 126 insertions, 0 deletions
diff --git a/sys-fs/quota/files/quota-4.04-glibc226.patch b/sys-fs/quota/files/quota-4.04-glibc226.patch
new file mode 100644
index 000000000000..5f63cde7d426
--- /dev/null
+++ b/sys-fs/quota/files/quota-4.04-glibc226.patch
@@ -0,0 +1,43 @@
+From bbb8819fc0f6ed379a05d635a61bcf9c8986079f Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Andreas=20K=2E=20H=C3=BCttel?= <dilfridge@gentoo.org>
+Date: Sat, 16 Sep 2017 13:09:43 +0200
+Subject: [PATCH] Add $(TIRPC_CFLAGS) globally to CFLAGS for RPC support,
+ needed for libc 2.26
+
+---
+ Makefile.am | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile.am b/Makefile.am
+index 8d80bee..278290a 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -51,6 +51,8 @@ EXTRA_DIST = \
+ noinst_LIBRARIES = libquota.a
+
+ if WITH_RPC
++CFLAGS += $(TIRPC_CFLAGS)
++
+ rpcsvcdir = $(includedir)/rpcsvc
+ rpcsvc_DATA = \
+ rquota.h \
+@@ -100,8 +102,6 @@ libquota_a_SOURCES = \
+ mntopt.h \
+ pot.c \
+ pot.h
+-libquota_a_CFLAGS = \
+- $(TIRPC_CFLAGS)
+ libquota_a_LIBADD = \
+ $(RPCLIBS)
+
+@@ -235,7 +235,6 @@ rpc_rquotad_SOURCES = \
+ rquota_server.c \
+ rquota_svc.c \
+ svc_socket.c
+-rpc_rquotad_CFLAGS = $(TIRPC_CFLAGS)
+ rpc_rquotad_LDADD = \
+ libquota.a \
+ $(WRAP_LIBS) \
+--
+2.14.1
+
diff --git a/sys-fs/quota/quota-4.04-r1.ebuild b/sys-fs/quota/quota-4.04-r1.ebuild
new file mode 100644
index 000000000000..0fccc223e077
--- /dev/null
+++ b/sys-fs/quota/quota-4.04-r1.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Linux quota tools"
+HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
+SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="ldap netlink nls rpc tcpd"
+
+RDEPEND="
+ ldap? ( >=net-nds/openldap-2.3.35 )
+ netlink? (
+ sys-apps/dbus
+ dev-libs/libnl:3
+ )
+ rpc? (
+ net-nds/rpcbind
+ || ( sys-libs/glibc[rpc(-)]
+ (
+ net-libs/rpcsvc-proto
+ )
+ )
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+PATCHES=(
+ "${FILESDIR}/${P}-glibc226.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --docdir="${EPREFIX%/}/usr/share/doc/${PF}"
+ $(use_enable nls)
+ $(use_enable ldap ldapmail)
+ $(use_enable netlink)
+ $(use_enable rpc)
+ $(use_enable rpc rpcsetquota)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc doc/* README.* Changelog
+
+ insinto /etc
+ insopts -m0644
+ doins warnquota.conf quotatab
+
+ newinitd "${FILESDIR}"/quota.rc7 quota
+ newconfd "${FILESDIR}"/quota.confd quota
+
+ if use rpc ; then
+ newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
+ fi
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ insopts -m0644
+ doins "${FILESDIR}"/ldap-scripts/quota.schema
+
+ exeinto /usr/share/quota/ldap-scripts
+ doexe "${FILESDIR}"/ldap-scripts/*.pl
+ doexe "${FILESDIR}"/ldap-scripts/edquota_editor
+ fi
+}