summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 09:18:36 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:11:08 +0100
commit61296d4818402eaeee009438a8b20ad73923b639 (patch)
tree7c191f201e41118983c658235ee8b687b971542a /sys-fs
parentsys-apps/lshw: tidy up patch (diff)
downloadgentoo-61296d4818402eaeee009438a8b20ad73923b639.tar.gz
gentoo-61296d4818402eaeee009438a8b20ad73923b639.tar.bz2
gentoo-61296d4818402eaeee009438a8b20ad73923b639.zip
sys-fs/mhddfs: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch6
-rw-r--r--sys-fs/mhddfs/mhddfs-0.1.39-r2.ebuild5
2 files changed, 7 insertions, 4 deletions
diff --git a/sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch b/sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch
index 278c9876da73..5a3dc51c1431 100644
--- a/sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch
+++ b/sys-fs/mhddfs/files/mhddfs-respect-compiler-vars.patch
@@ -1,12 +1,12 @@
---- a/Makefile 2012-11-19 15:25:21.665692111 +0400
-+++ b/Makefile 2012-11-19 15:27:08.406691288 +0400
+--- a/Makefile
++++ b/Makefile
@@ -22,13 +22,13 @@
TARGET = mhddfs
-CFLAGS = -Wall $(shell pkg-config fuse --cflags) \
- -DFUSE_USE_VERSION=26 -MMD
-+CFLAGS += -Wall $(shell pkg-config fuse glib-2.0 --cflags) \
++CFLAGS += -Wall $(shell ${PKG_CONFIG} fuse glib-2.0 --cflags) \
+ -DFUSE_USE_VERSION=26 -MMD -rdynamic
ifdef WITHOUT_XATTR
CFLAGS += -DWITHOUT_XATTR
diff --git a/sys-fs/mhddfs/mhddfs-0.1.39-r2.ebuild b/sys-fs/mhddfs/mhddfs-0.1.39-r2.ebuild
index 78ca180e4bb5..201ecb8f7ae5 100644
--- a/sys-fs/mhddfs/mhddfs-0.1.39-r2.ebuild
+++ b/sys-fs/mhddfs/mhddfs-0.1.39-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -22,6 +22,7 @@ RDEPEND="
sys-fs/fuse:0
"
DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
DOCS=( ChangeLog README )
PATCHES=(
@@ -31,6 +32,8 @@ PATCHES=(
)
src_compile() {
+ tc-export PKG_CONFIG
+
emake CC="$(tc-getCC)"
}