summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2021-09-22 12:52:25 +0200
committerLars Wendler <polynomial-c@gentoo.org>2021-09-22 12:57:58 +0200
commit653f7437b37b5b99ce5bcce5495521df93adabdc (patch)
treee6e21d218a737c5da2361b738a9594ef00e37674 /sys-fs
parentsys-kernel/vanilla-sources: Linux version bumps (diff)
downloadgentoo-653f7437b37b5b99ce5bcce5495521df93adabdc.tar.gz
gentoo-653f7437b37b5b99ce5bcce5495521df93adabdc.tar.bz2
gentoo-653f7437b37b5b99ce5bcce5495521df93adabdc.zip
sys-fs/inotify-tools: Bump to version 3.21.9.5
Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/inotify-tools/Manifest1
-rw-r--r--sys-fs/inotify-tools/inotify-tools-3.21.9.5.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/sys-fs/inotify-tools/Manifest b/sys-fs/inotify-tools/Manifest
index 82977ba73d39..3f29cd52b4b5 100644
--- a/sys-fs/inotify-tools/Manifest
+++ b/sys-fs/inotify-tools/Manifest
@@ -2,3 +2,4 @@ DIST inotify-tools-3.20.11.0.tar.gz 84827 BLAKE2B 1d3e25c4e213c9c6da74575677a6dc
DIST inotify-tools-3.20.2.2.tar.gz 81006 BLAKE2B 7dd29985f68096fe2146a3ad84d619b3d1238b0db25eeb125f2fe9591fa678078351f00c7e09b526cf2251e4736201d5625ff0e477523cae370a307ccb667730 SHA512 72d6fdcc216d8083cd384c71c02dc8e800d3a9702613568b3c571f704aee3d42bf084c52f2141c9afb8d28e8b87ebb6391ed3d825b3d664ed51c552debeb1881
DIST inotify-tools-3.21.9.0.tar.gz 91321 BLAKE2B 2c9ca20e8dbc096730351e86eba675ceb2891fb9e60c07c6aec9bcc071217d6972437e3b9bd03930b83fa8dd5476995e97f329d6ade02ff61a71a520ead79c5f SHA512 05535469ebb60ad98d5436a5145be880fef10ec9f15adc94c98e98e20fcb2af9ccab150a518275747fa82dfc29006eb0baca28f7b38cb25de9c92a9ea6bd9b19
DIST inotify-tools-3.21.9.1.tar.gz 91378 BLAKE2B a7d5d7ed2f63e186ed68d42ec443c43ae75e575d553221a11cd6991421d5d5b8c5447144a2e5cbc7dbad1d603e3cc120429ef5c91ac67994a82ea530c54142c0 SHA512 2a4d9f2e98b1f0263745c533fc06cd9f23bf9c793e9a8a3a944c7312f8d2b8e223caafbdd17b81e6dc0e29d85dd1730aef9341ed282992b4333d6d79cbfb3f99
+DIST inotify-tools-3.21.9.5.tar.gz 91711 BLAKE2B cf6575cdd445a823c8272a9f8394ed241af1cc729784ec363c9dac6cd3c5cf37856076e88d389669d9da768b899e7ecb64c997e25b42cd5fccc2ebbbf145b273 SHA512 d0ae070f4fa3ea261913bba4ed6edf865aa8ddb9235cf5e967d11f54168a78d92739a5110a1afbdedbe3e6f0cbaf395883e2d47a182c9e6847986da184a52a97
diff --git a/sys-fs/inotify-tools/inotify-tools-3.21.9.5.ebuild b/sys-fs/inotify-tools/inotify-tools-3.21.9.5.ebuild
new file mode 100644
index 000000000000..1cc912c8d9cc
--- /dev/null
+++ b/sys-fs/inotify-tools/inotify-tools-3.21.9.5.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="a set of command-line programs providing a simple interface to inotify"
+HOMEPAGE="https://github.com/inotify-tools/inotify-tools"
+SRC_URI="https://github.com/${PN}/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~mips ~sparc ~x86"
+IUSE="doc"
+
+BDEPEND="doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ default
+
+ # Remove -Werror from CFLAGS (#745069)
+ find -name "Makefile.am" -print0 \
+ | xargs --null sed 's@ -Werror@@' -i || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # only docs installed are doxygen ones, so use /html
+ local myeconfargs=(
+ --disable-static
+ --docdir='$(datarootdir)'/doc/${PF}/html
+ $(use_enable doc doxygen)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -type f -name '*.la' -delete || die
+}