summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-10 13:50:55 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-13 12:54:26 +0100
commit65945ac3f12742d6d6d40b8d9f268bf4f75997d0 (patch)
tree40a1e7355e7944c824752831cdb317a4a4c07bdc /sys-fs
parentdist-kernel-utils.eclass: Add a function to rebuild initramfs (diff)
downloadgentoo-65945ac3f12742d6d6d40b8d9f268bf4f75997d0.tar.gz
gentoo-65945ac3f12742d6d6d40b8d9f268bf4f75997d0.tar.bz2
gentoo-65945ac3f12742d6d6d40b8d9f268bf4f75997d0.zip
sys-fs/zfs-kmod: Rebuild initramfs after installing
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild6
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-2.0.1.ebuild6
-rw-r--r--sys-fs/zfs-kmod/zfs-kmod-9999.ebuild6
3 files changed, 15 insertions, 3 deletions
diff --git a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
index 0a5097f63941..6c07ba52c3ae 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-0.8.6.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic linux-mod toolchain-funcs
+inherit autotools dist-kernel-utils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
HOMEPAGE="https://github.com/openzfs/zfs"
@@ -158,6 +158,10 @@ pkg_postinst() {
rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
fi
+ if [[ -z ${ROOT} ]] && use dist-kernel; then
+ dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
+ fi
+
if use x86 || use arm; then
ewarn "32-bit kernels will likely require increasing vmalloc to"
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
diff --git a/sys-fs/zfs-kmod/zfs-kmod-2.0.1.ebuild b/sys-fs/zfs-kmod/zfs-kmod-2.0.1.ebuild
index 4ea7b063affe..2fbfd85f7ccf 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-2.0.1.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-2.0.1.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic linux-mod toolchain-funcs
+inherit autotools dist-kernel-utils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
HOMEPAGE="https://github.com/openzfs/zfs"
@@ -149,6 +149,10 @@ pkg_postinst() {
rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
fi
+ if [[ -z ${ROOT} ]] && use dist-kernel; then
+ dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
+ fi
+
if use x86 || use arm; then
ewarn "32-bit kernels will likely require increasing vmalloc to"
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."
diff --git a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
index 4ea7b063affe..2fbfd85f7ccf 100644
--- a/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
+++ b/sys-fs/zfs-kmod/zfs-kmod-9999.ebuild
@@ -3,7 +3,7 @@
EAPI=7
-inherit autotools flag-o-matic linux-mod toolchain-funcs
+inherit autotools dist-kernel-utils flag-o-matic linux-mod toolchain-funcs
DESCRIPTION="Linux ZFS kernel module for sys-fs/zfs"
HOMEPAGE="https://github.com/openzfs/zfs"
@@ -149,6 +149,10 @@ pkg_postinst() {
rmdir --ignore-fail-on-non-empty "${EROOT}/lib/modules/${KV_FULL}/addon"
fi
+ if [[ -z ${ROOT} ]] && use dist-kernel; then
+ dist-kernel_reinstall_initramfs "${KV_DIR}" "${KV_FULL}"
+ fi
+
if use x86 || use arm; then
ewarn "32-bit kernels will likely require increasing vmalloc to"
ewarn "at least 256M and decreasing zfs_arc_max to some value less than that."