summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-12-26 08:29:59 +0000
committerSam James <sam@gentoo.org>2022-12-26 08:33:06 +0000
commit6bb6fbc076b1d9e9cf16bb9af8e79c672ec42203 (patch)
treec775eea828ae27d32e36bc73d4d9f55e3b879866 /sys-fs
parentsys-fs/multipath-tools: drop 0.8.9, 0.9.0, 0.9.3-r2 (diff)
downloadgentoo-6bb6fbc076b1d9e9cf16bb9af8e79c672ec42203.tar.gz
gentoo-6bb6fbc076b1d9e9cf16bb9af8e79c672ec42203.tar.bz2
gentoo-6bb6fbc076b1d9e9cf16bb9af8e79c672ec42203.zip
sys-fs/quota: drop 4.06-r1
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/quota/Manifest1
-rw-r--r--sys-fs/quota/files/quota-4.06-musl-cdefs.patch20
-rw-r--r--sys-fs/quota/quota-4.06-r1.ebuild82
3 files changed, 0 insertions, 103 deletions
diff --git a/sys-fs/quota/Manifest b/sys-fs/quota/Manifest
index c18c1f799be4..de8eeb05f7a9 100644
--- a/sys-fs/quota/Manifest
+++ b/sys-fs/quota/Manifest
@@ -1,2 +1 @@
-DIST quota-4.06.tar.gz 520448 BLAKE2B 2cbadeade228d0154f3a8d455cc1aa6e85c9ad7854007e3188c9035abe4d5fdbdf97985fd2fa6308f486ffbe60461e0fe1139f1ec0ca415ce08292d74e0ddde1 SHA512 cece46b8e3a82e8afcf8bfc9f6b310ec91afe034102cebc031bc7d7e04287fdbffb21ab1d3e6e1825175cffa4bad0a4ecbefec0efee028d961b14ac626d5c871
DIST quota-4.09.tar.gz 523191 BLAKE2B 30b3828a45dcd7d99ff053f362917c138b1f0bcbde5f6fd3dfc1b48cb12615e5673d852f9276f2b370f9c799a2103e220d91ddf6a770aaaf8944cfb5c1131a74 SHA512 003d45f33543d4c87446e6547079cdae293b8dade01c58cf3626623721a1400ee07681395ad656c23a9ea2a62ab27c6ad24ad55600890e6e25334aba27ab1ad5
diff --git a/sys-fs/quota/files/quota-4.06-musl-cdefs.patch b/sys-fs/quota/files/quota-4.06-musl-cdefs.patch
deleted file mode 100644
index 286fc481b6b3..000000000000
--- a/sys-fs/quota/files/quota-4.06-musl-cdefs.patch
+++ /dev/null
@@ -1,20 +0,0 @@
-https://sourceforge.net/p/linuxquota/code/ci/1959f3768a284315250acd4d17a9f5ef0b8ea189/tree/quota.h?diff=43b6e31f39edbe7de4f4feeef4d0cf6be093e021
-https://bugs.gentoo.org/713390
---- a/quota.h
-+++ b/quota.h
-@@ -1,7 +1,6 @@
- #ifndef GUARD_QUOTA_H
- #define GUARD_QUOTA_H
-
--#include <sys/cdefs.h>
- #include <sys/types.h>
- #include <stdint.h>
-
-@@ -182,6 +181,6 @@
- #endif
- #endif
-
--long quotactl __P((int, const char *, qid_t, caddr_t));
-+long quotactl(int, const char *, qid_t, caddr_t);
-
- #endif /* _QUOTA_ */
diff --git a/sys-fs/quota/quota-4.06-r1.ebuild b/sys-fs/quota/quota-4.06-r1.ebuild
deleted file mode 100644
index 60b635e13264..000000000000
--- a/sys-fs/quota/quota-4.06-r1.ebuild
+++ /dev/null
@@ -1,82 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools
-
-DESCRIPTION="Linux quota tools"
-HOMEPAGE="https://sourceforge.net/projects/linuxquota/"
-SRC_URI="mirror://sourceforge/linuxquota/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~riscv sparc x86"
-IUSE="ldap netlink nls rpc tcpd"
-
-RDEPEND="
- sys-fs/e2fsprogs
- ldap? ( >=net-nds/openldap-2.3.35:= )
- netlink? (
- sys-apps/dbus
- dev-libs/libnl:3
- )
- rpc? (
- elibc_glibc? ( sys-libs/glibc[-rpc(-)] )
- net-libs/libtirpc:=
- net-libs/rpcsvc-proto
- )
- tcpd? ( sys-apps/tcp-wrappers )
-"
-DEPEND="${RDEPEND}"
-BDEPEND="nls? ( sys-devel/gettext )"
-PDEPEND="rpc? ( net-nds/rpcbind )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-musl-cdefs.patch
-)
-
-src_prepare() {
- default
-
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- --enable-ext2direct
- $(use_enable nls)
- $(use_enable ldap ldapmail)
- $(use_enable netlink)
- $(use_enable rpc)
- $(use_enable rpc rpcsetquota)
- )
-
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- emake DESTDIR="${D}" install
- dodoc doc/* README.* Changelog
-
- insinto /etc
- insopts -m0644
- doins warnquota.conf quotatab
-
- newinitd "${FILESDIR}"/quota.rc7 quota
- newconfd "${FILESDIR}"/quota.confd quota
-
- if use rpc ; then
- newinitd "${FILESDIR}"/rpc.rquotad.initd rpc.rquotad
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema
- insopts -m0644
- doins "${FILESDIR}"/ldap-scripts/quota.schema
-
- exeinto /usr/share/quota/ldap-scripts
- doexe "${FILESDIR}"/ldap-scripts/*.pl
- doexe "${FILESDIR}"/ldap-scripts/edquota_editor
- fi
-}