summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-03-25 04:20:24 +0000
committerSam James <sam@gentoo.org>2023-03-25 04:22:52 +0000
commit73b136f94db0e4b3ebfaa46ddca842fde4585619 (patch)
treea34725b9a44e0759c5a2e4c29340073057890fc9 /sys-fs
parentapp-portage/tatt: drop myself as a maintainer (diff)
downloadgentoo-73b136f94db0e4b3ebfaa46ddca842fde4585619.tar.gz
gentoo-73b136f94db0e4b3ebfaa46ddca842fde4585619.tar.bz2
gentoo-73b136f94db0e4b3ebfaa46ddca842fde4585619.zip
sys-fs/xfsprogs: add 6.2.0
Implicit func. decls fixed in https://git.kernel.org/pub/scm/fs/xfs/xfsprogs-dev.git/commit/?id=d6642ab8cc934d9de12de631f5b0b3098022eb02. Closes: https://bugs.gentoo.org/898618 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/Manifest1
-rw-r--r--sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild95
2 files changed, 96 insertions, 0 deletions
diff --git a/sys-fs/xfsprogs/Manifest b/sys-fs/xfsprogs/Manifest
index 2d9cc0b20230..2af549a11791 100644
--- a/sys-fs/xfsprogs/Manifest
+++ b/sys-fs/xfsprogs/Manifest
@@ -1,3 +1,4 @@
DIST xfsprogs-5.18.0.tar.xz 1310008 BLAKE2B a2a2835d53ee6ac55279636f3f3cdcecab8757911ce5c1ea5f350a4da9ff4c1ca64b2aba1c0e5424c0c0a01fd0504396d5fecca12e4689c372ed5bb76b9ac24e SHA512 47d035a33367edae7357e34c70bdb0fe9219231153fb4c4f418ed1462d137dd77338c12a199eb71cd70e88903e5fc11e1e4fb595c622183786e87346e2f65739
DIST xfsprogs-6.0.0.tar.xz 1320744 BLAKE2B ae1d175e3dc5f0f6819397f8166a419847da07616d472f81928e3086b9fac420c09e9406d752a34a957d6d9c82a45defb17d6773e87e3b5f4ff509952ef3e76e SHA512 a3ddccdea1129038420d933f1e9ae8f9e75b3ad59fd0fe4c61b7a4dc6145f47b4262f68aefc3216d37cc33ee5643cd6f260ec83cd39d6b61a1cd046c03674ad8
DIST xfsprogs-6.1.1.tar.xz 1322528 BLAKE2B f6551356ccc68ee6d0bdc50edcf9717bfc94053e97b408f0fa6b316d51391bd347baa8c6ce09e269d09177eec14befc4235738e92d5e4408bda1113c79b2b18b SHA512 ec11cb9be34502a006f18ebea0a62aa227580753fce57cb7b6394d079fa41aee778382c06116a2fa45b67989a1501bbba2013829d2348b51e1136e668966c5e6
+DIST xfsprogs-6.2.0.tar.xz 1324216 BLAKE2B 847ad267b3667604c9c6a30857605e9cef0f184b7c375d0771b29a0c9596f621a819cc4e88af939a3f9a3ce14a2984fece5e70346bc673a5982af6eebe3909cc SHA512 71c04f744af9f4f3197a9c6eb468574d984c1532753f83f0bcd583cf737b89fab034442c072794975c813ea168572b39ae43f28d9a0428204be2fb7f1e141fc5
diff --git a/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild b/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild
new file mode 100644
index 000000000000..0fcec175114a
--- /dev/null
+++ b/sys-fs/xfsprogs/xfsprogs-6.2.0.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic systemd usr-ldscript
+
+DESCRIPTION="XFS filesystem utilities"
+HOMEPAGE="https://xfs.wiki.kernel.org/"
+SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="icu libedit nls selinux"
+
+RDEPEND="dev-libs/inih
+ dev-libs/userspace-rcu:=
+ >=sys-apps/util-linux-2.17.2
+ icu? ( dev-libs/icu:= )
+ libedit? ( dev-libs/libedit )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+RDEPEND+=" selinux? ( sec-policy/selinux-xfs )"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-5.3.0-libdir.patch
+ "${FILESDIR}"/${PN}-5.18.0-docdir.patch
+)
+
+src_prepare() {
+ default
+
+ # Fix doc dir
+ sed -i \
+ -e "/^PKG_DOC_DIR/s:@pkg_name@:${PF}:" \
+ include/builddefs.in || die
+
+ # Don't install compressed docs
+ sed 's@\(CHANGES\)\.gz[[:space:]]@\1 @' -i doc/Makefile || die
+}
+
+src_configure() {
+ # include/builddefs.in will add FCFLAGS to CFLAGS which will
+ # unnecessarily clutter CFLAGS (and fortran isn't used)
+ unset FCFLAGS
+
+ # If set in user env, this breaks configure
+ unset PLATFORM
+
+ export DEBUG=-DNDEBUG
+
+ # Package is honoring CFLAGS; No need to use OPTIMIZER anymore.
+ # However, we have to provide an empty value to avoid default
+ # flags.
+ export OPTIMIZER=" "
+
+ # Avoid automagic on libdevmapper (bug #709694)
+ export ac_cv_search_dm_task_create=no
+
+ # Build fails with -O3 (bug #712698)
+ replace-flags -O3 -O2
+
+ # Upstream does NOT support --disable-static anymore,
+ # https://www.spinics.net/lists/linux-xfs/msg30185.html
+ # https://www.spinics.net/lists/linux-xfs/msg30272.html
+ local myconf=(
+ --enable-static
+ --enable-blkid
+ --with-crond-dir="${EPREFIX}/etc/cron.d"
+ --with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
+ $(use_enable nls gettext)
+ $(use_enable libedit editline)
+ )
+
+ if is-flagq -flto ; then
+ myconf+=( --enable-lto )
+ else
+ myconf+=( --disable-lto )
+ fi
+
+ econf "${myconf[@]}"
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install
+ emake DIST_ROOT="${ED}" HAVE_ZIPPED_MANPAGES=false install-dev
+
+ gen_usr_ldscript -a handle
+}