summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTheo Anderson <telans@posteo.de>2020-12-24 13:21:58 +1300
committerJoonas Niilola <juippis@gentoo.org>2021-01-04 15:55:58 +0200
commit7bdcbe60c6eab1d4f4973b8df5eb9ac32669a647 (patch)
tree531a98c3a6f79385feb30c8bd2ad65b041307371 /sys-fs
parentsys-fs/bees: update live ebuild (diff)
downloadgentoo-7bdcbe60c6eab1d4f4973b8df5eb9ac32669a647.tar.gz
gentoo-7bdcbe60c6eab1d4f4973b8df5eb9ac32669a647.tar.bz2
gentoo-7bdcbe60c6eab1d4f4973b8df5eb9ac32669a647.zip
sys-fs/bees: bump to 0.6.4
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Theo Anderson <telans@posteo.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/bees/Manifest1
-rw-r--r--sys-fs/bees/bees-0.6.4.ebuild92
-rw-r--r--sys-fs/bees/bees-9999.ebuild6
3 files changed, 96 insertions, 3 deletions
diff --git a/sys-fs/bees/Manifest b/sys-fs/bees/Manifest
index e8d393d0f838..c43cefc6e650 100644
--- a/sys-fs/bees/Manifest
+++ b/sys-fs/bees/Manifest
@@ -1 +1,2 @@
DIST bees-0.6.1.tar.gz 124411 BLAKE2B fd6c875334cb610da94a4633351b7edc5a4ecf4ff467bb93c8559a1698fd29667d43955e0031498401ceeb3d8db13b5aeb80d2f16cd61e4d5a6607e432082c79 SHA512 cd44d21959d3ab4dda255f0a4a57bd3aeecfb9fee6ea26d68a1b5f84d407f75bd0b442ecf4fefc5ac856dcd9af035f44ceeff77a8926b164f97a15350efcee33
+DIST bees-0.6.4.tar.gz 126064 BLAKE2B 562f0cfd63d15978a26f859548eb36cea0bf1be8e363c7ee5d2294e3c6407b4a93d865ffe2d15fabaeb2b3e136ad2d48cab3210c00e5fe39432985186ad62c55 SHA512 ce0eb66ac0770838e13ba6007fd765c02aea3f5eefc09e2834118d420e71693c37b8aa8511cfc9577ca09ab82d37787a1854edbed090c059759b29c70d834672
diff --git a/sys-fs/bees/bees-0.6.4.ebuild b/sys-fs/bees/bees-0.6.4.ebuild
new file mode 100644
index 000000000000..6c38f7b9c91e
--- /dev/null
+++ b/sys-fs/bees/bees-0.6.4.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit linux-info systemd
+
+DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
+HOMEPAGE="https://github.com/Zygo/bees"
+
+if [[ ${PV} == 9999 ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Zygo/bees.git"
+else
+ SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64"
+fi
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="tools"
+
+DEPEND="
+ >=sys-apps/util-linux-2.30.2
+ >=sys-fs/btrfs-progs-4.20.2
+"
+RDEPEND="${DEPEND}"
+
+CONFIG_CHECK="~BTRFS_FS"
+ERROR_BTRFS_FS="CONFIG_BTRFS_FS: bees does currently only work with btrfs"
+
+PATCHES=( "${FILESDIR}/0001-HACK-musl-does-not-define-pthread_getname_np.patch" )
+
+pkg_pretend() {
+ if [[ ${MERGE_TYPE} != buildonly ]]; then
+ if kernel_is -lt 4 11; then
+ ewarn "With kernel versions below 4.11, bees may severely degrade system performance"
+ ewarn "and responsiveness. Especially, the kernel may deadlock while bees is"
+ ewarn "running, it's recommended to run at least kernel 4.11."
+ ewarn
+ elif kernel_is -lt 4 14 29; then
+ ewarn "With kernel versions below 4.14.29, bees may generate a lot of bogus WARN_ON()"
+ ewarn "messages in the kernel log. These messages can be ignored and this is fixed"
+ ewarn "with more recent kernels:"
+ ewarn "# WARNING: CPU: 3 PID: 18172 at fs/btrfs/backref.c:1391 find_parent_nodes+0xc41/0x14e0"
+ ewarn
+ fi
+ if kernel_is -lt 5 1 0; then
+ ewarn "IMPORTANT: With kernel versions below 5.1.0, you may experience data corruption"
+ ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
+ ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
+ ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"
+ ewarn "# commit 8e92821 btrfs: fix corruption reading shared and compressed extents after hole punching"
+ ewarn
+ fi
+ if kernel_is -lt 5 3 4; then
+ ewarn "With kernel versions below 5.3.4, bees may trigger a btrfs bug when running"
+ ewarn "btrfs-balance in parallel. This may lead to meta-data corruption in the worst"
+ ewarn "case. Especially, kernels 5.1.21 and 5.2.21 should be avoided. Kernels 5.0.x"
+ ewarn "after 5.0.21 should be safe. In the best case, affected kernels may force"
+ ewarn "the device RO without writing corrupted meta-data. More details:"
+ ewarn "https://github.com/Zygo/bees/blob/master/docs/btrfs-kernel.md"
+ ewarn
+ fi
+
+ elog "Bees recommends running the latest current kernel for performance and"
+ elog "reliability reasons, see README.md."
+ fi
+}
+
+src_prepare() {
+ default
+ sed -i 's/ -Werror//' makeflags || die
+}
+
+src_configure() {
+ cat >localconf <<-EOF || die
+ LIBEXEC_PREFIX=/usr/libexec
+ PREFIX=/usr
+ LIBDIR="$(get_libdir)"
+ SYSTEMD_SYSTEM_UNIT_DIR="$(systemd_get_systemunitdir)"
+ DEFAULT_MAKE_TARGET=all
+ EOF
+ if [[ ${PV} != "9999" ]] ; then
+ cat >>localconf <<-EOF || die
+ BEES_VERSION=v${PV}
+ EOF
+ fi
+ if use tools; then
+ echo OPTIONAL_INSTALL_TARGETS=install_tools >>localconf || die
+ fi
+}
diff --git a/sys-fs/bees/bees-9999.ebuild b/sys-fs/bees/bees-9999.ebuild
index 6c04e62724b7..6c38f7b9c91e 100644
--- a/sys-fs/bees/bees-9999.ebuild
+++ b/sys-fs/bees/bees-9999.ebuild
@@ -8,9 +8,9 @@ inherit linux-info systemd
DESCRIPTION="Best-Effort Extent-Same, a btrfs dedup agent"
HOMEPAGE="https://github.com/Zygo/bees"
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/Zygo/bees.git"
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
+ EGIT_REPO_URI="https://github.com/Zygo/bees.git"
else
SRC_URI="https://github.com/Zygo/bees/archive/v${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm64"
@@ -46,7 +46,7 @@ pkg_pretend() {
ewarn
fi
if kernel_is -lt 5 1 0; then
- ewarn "IMPORTANT: With kernel versions below 5.0.4, you may experience data corruption"
+ ewarn "IMPORTANT: With kernel versions below 5.1.0, you may experience data corruption"
ewarn "due to bees using compression in btrfs. You are adviced to use a chronologically"
ewarn "later kernel, that includes older LTS versions released after 5.0.4:"
ewarn "Fixed in: 5.1+, 5.0.4+, 4.19.31+, 4.14.108+, 4.9.165+, 4.4.177+, 3.18.137+"