summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2021-10-01 00:20:05 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2021-10-01 00:20:33 +0200
commit8c778578a4f5e73a7edff20e09d35afbac7a8c06 (patch)
tree8e735879ac8fe9b0418dfd4100d4ef7652f93cbd /sys-fs
parentapp-misc/jpipe: PYTHON_DEPS and PYTHON_REQUIRED_USE (diff)
downloadgentoo-8c778578a4f5e73a7edff20e09d35afbac7a8c06.tar.gz
gentoo-8c778578a4f5e73a7edff20e09d35afbac7a8c06.tar.bz2
gentoo-8c778578a4f5e73a7edff20e09d35afbac7a8c06.zip
sys-fs/mtpfs: fix deprecated init of lock
This became an error with glib 2.70 Closes: https://bugs.gentoo.org/814965 Package-Manager: Portage-3.0.26, Repoman-3.0.3 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/mtpfs/files/mtpfs-1.1-deprecated_lock_init.patch24
-rw-r--r--sys-fs/mtpfs/mtpfs-1.1-r6.ebuild3
2 files changed, 26 insertions, 1 deletions
diff --git a/sys-fs/mtpfs/files/mtpfs-1.1-deprecated_lock_init.patch b/sys-fs/mtpfs/files/mtpfs-1.1-deprecated_lock_init.patch
new file mode 100644
index 000000000000..d369ebfe1f2a
--- /dev/null
+++ b/sys-fs/mtpfs/files/mtpfs-1.1-deprecated_lock_init.patch
@@ -0,0 +1,24 @@
+diff -Naur mtpfs-1.1.orig/mtpfs.c mtpfs-1.1/mtpfs.c
+--- mtpfs-1.1.orig/mtpfs.c 2021-10-01 00:15:15.763423589 +0200
++++ mtpfs-1.1/mtpfs.c 2021-10-01 00:16:07.626486888 +0200
+@@ -1371,6 +1371,8 @@
+ extern int optind;
+ extern char *optarg;
+
++ g_mutex_init(&device_lock);
++
+ //while ((opt = getopt(argc, argv, "d")) != -1 ) {
+ //switch (opt) {
+ //case 'd':
+diff -Naur mtpfs-1.1.orig/mtpfs.h mtpfs-1.1/mtpfs.h
+--- mtpfs-1.1.orig/mtpfs.h 2021-10-01 00:15:15.779423609 +0200
++++ mtpfs-1.1/mtpfs.h 2021-10-01 00:16:20.322502337 +0200
+@@ -77,7 +77,7 @@
+ static GSList *myfiles = NULL;
+ static LIBMTP_playlist_t *playlists = NULL;
+ static gboolean playlists_changed = FALSE;
+-static GMutex device_lock = G_STATIC_MUTEX_INIT;
++static GMutex device_lock;
+
+
+ #endif /* _MTPFS_H_ */
diff --git a/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild b/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
index 3bc2351e26c1..04dd5b86b903 100644
--- a/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
+++ b/sys-fs/mtpfs/mtpfs-1.1-r6.ebuild
@@ -27,7 +27,8 @@ DOCS=(AUTHORS NEWS README)
PATCHES=( "${FILESDIR}"/${P}-fix-mutex-crash.patch
"${FILESDIR}"/${P}-unitialized-variable.patch
"${FILESDIR}"/${P}-wking-patches/
- "${FILESDIR}"/${P}-g_printf.patch )
+ "${FILESDIR}"/${P}-g_printf.patch
+ "${FILESDIR}"/${P}-deprecated_lock_init.patch )
src_prepare() {
default