summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-07-25 17:00:15 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-07-25 17:05:57 -0400
commit95e53bf74a93acdc5ff2c74724d3831bc701e055 (patch)
tree56dc3aabd7905803db787e6854bd4e73a489f606 /sys-fs
parentdev-lang/elixir: bump up to 1.5.0 (diff)
downloadgentoo-95e53bf74a93acdc5ff2c74724d3831bc701e055.tar.gz
gentoo-95e53bf74a93acdc5ff2c74724d3831bc701e055.tar.bz2
gentoo-95e53bf74a93acdc5ff2c74724d3831bc701e055.zip
sys-fs/simple-mtpfs: new version 0.3.0.
This new version comes with a new EAPI=6. To avoid the autotools-utils eclass, I had to introduce an src_prepare() phase that calls eautoreconf. I also dropped the "9999" stuff for simplicity. Gentoo-Bug: 619502 Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/simple-mtpfs/Manifest2
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild30
-rw-r--r--sys-fs/simple-mtpfs/simple-mtpfs-0.3.0.ebuild30
3 files changed, 31 insertions, 31 deletions
diff --git a/sys-fs/simple-mtpfs/Manifest b/sys-fs/simple-mtpfs/Manifest
index 7a5f16ea777d..1bbb149769f0 100644
--- a/sys-fs/simple-mtpfs/Manifest
+++ b/sys-fs/simple-mtpfs/Manifest
@@ -1,2 +1,2 @@
DIST simple-mtpfs-0.1.tar.gz 116145 SHA256 052618c742e7b3faa95e1c84e8b9e1df1517dccb9460f538bb032223243588a1 SHA512 5c4b390c43ede521061c677b496d47376304a4625414853a2183a41cb4a2c67361ecd7e26d0b6197cc78e84d0a9c99ec92e85bd1c179784b5a7c06ae05ede308 WHIRLPOOL 4df83ffc56339df76124e22f93df8fcf188cad30da83f8a9349e5a8ad8ff64010a0d118bcd4a9719ee0e9a5e3cf2fd997af6f3220951792a5e8f00da3d4a0291
-DIST simple-mtpfs-0.2.tar.gz 35003 SHA256 3ce41fb194971041aa6ad15292a6cdad70eb8b5fc3e7a03a638bc3cac0c515ea SHA512 adb844288af214802ab6e0ddf949d2dc97ec03289db4b68c6b08da00534cdd48f621d8a52287b18d7826cabd78ddad2ca7ded6337016432c473e26c4c6f3c9e5 WHIRLPOOL 9b19d026da2786e8bd08b7c2ea4372cca6bb36e346e0430233af516db50c6d72cef88d65c5da92333941e353534fd486b932573602ea540bd0ba51117ea4c94c
+DIST simple-mtpfs-0.3.0.tar.gz 36655 SHA256 5556cae4414254b071d79ce656cce866b42fd7ba40ce480abfc3ba4e357cd491 SHA512 7d2da152708c01ddd2a39c1b56cba6470bfd320b92507530cdd8fc4f25f9500ff817eac6a5d19c775f31029ae6a0baef693987c59453c60c688b84934378f772 WHIRLPOOL ef6c619e8942568f41ff03fed4e926af1b62ba22fd3b0f4db7ae675bec03b37da5b05d44a95d6e3db1e3912320492253ca1fd42034ff77293125ce2255530a0c
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
deleted file mode 100644
index 0dbbfdb919c0..000000000000
--- a/sys-fs/simple-mtpfs/simple-mtpfs-0.2.ebuild
+++ /dev/null
@@ -1,30 +0,0 @@
-# Copyright 1999-2015 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-EGIT_REPO_URI="git://github.com/phatina/${PN}.git"
-inherit autotools-utils eutils
-[[ ${PV} == 9999 ]] && inherit git-r3
-
-DESCRIPTION="Simple MTP fuse filesystem driver"
-HOMEPAGE="https://github.com/phatina/simple-mtpfs"
-[[ ${PV} == 9999 ]] || SRC_URI="https://github.com/phatina/${PN}/archive/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-[[ ${PV} == 9999 ]] || \
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-RDEPEND="
- media-libs/libmtp
- >=sys-fs/fuse-2.8
-"
-DEPEND="${RDEPEND}
- virtual/pkgconfig
-"
-
-[[ ${PV} == 9999 ]] || S="${WORKDIR}/${PN}-${P}"
-
-AUTOTOOLS_AUTORECONF=1
diff --git a/sys-fs/simple-mtpfs/simple-mtpfs-0.3.0.ebuild b/sys-fs/simple-mtpfs/simple-mtpfs-0.3.0.ebuild
new file mode 100644
index 000000000000..91269a3c30f3
--- /dev/null
+++ b/sys-fs/simple-mtpfs/simple-mtpfs-0.3.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="Simple MTP fuse filesystem driver"
+HOMEPAGE="https://github.com/phatina/simple-mtpfs"
+SRC_URI="${HOMEPAGE}/archive/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="media-libs/libmtp
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+
+ # The tarball doesn't contain ./configure, only configure.ac and
+ # autogen.sh.
+ eautoreconf
+}