summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorDaniel Pielmeier <billie@gentoo.org>2021-09-30 19:07:36 +0200
committerDaniel Pielmeier <billie@gentoo.org>2021-09-30 19:07:36 +0200
commit9a27ebe0db2fb73bfcbd1f02b5496524b42d7134 (patch)
tree73693f7d75ca01ed7776f17db6e877ca36bbe524 /sys-fs
parentnet-print/hplip: Version bump. (diff)
downloadgentoo-9a27ebe0db2fb73bfcbd1f02b5496524b42d7134.tar.gz
gentoo-9a27ebe0db2fb73bfcbd1f02b5496524b42d7134.tar.bz2
gentoo-9a27ebe0db2fb73bfcbd1f02b5496524b42d7134.zip
sys-fs/fatsort: Version bump.
Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Daniel Pielmeier <billie@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fatsort/Manifest1
-rw-r--r--sys-fs/fatsort/fatsort-1.6.4.625.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/sys-fs/fatsort/Manifest b/sys-fs/fatsort/Manifest
index 13e5a1b20862..f4ffba9723bb 100644
--- a/sys-fs/fatsort/Manifest
+++ b/sys-fs/fatsort/Manifest
@@ -1 +1,2 @@
DIST fatsort-1.6.3.622.tar.xz 123644 BLAKE2B 1db530753bdaee4ebda9ab36a47f6794584bc590de4cbf8d144a5baa770c080c9d27a1ecadd5a22de72538887c4e10f161f3c4fb3afb3e63bd18834897ebe905 SHA512 309c7424e53fb74f57d0c4272a1a4b3df57fa1130d7e7adae0ac73ac1c8b1900504e49efd0cc4dafea3efa2fbc9191f343b10bb97b647dd6124197356cd01c53
+DIST fatsort-1.6.4.625.tar.xz 123964 BLAKE2B 4d958886af48e9f6d6a39b128b5ff96b809e67667026483a5abfb3db6f16d8a5ebb257433f2a7fbba6c7e4d81614477cc4cec437bcfba868a2c2fb6b13b15c42 SHA512 1d67c3cb515295d0a47054803e5b2a625875e71f41b2fad17f9d495b6aa4a291776696692545800bb4d5b826e9d622ea34077c81f7f08f41b8dfd70491e439ef
diff --git a/sys-fs/fatsort/fatsort-1.6.4.625.ebuild b/sys-fs/fatsort/fatsort-1.6.4.625.ebuild
new file mode 100644
index 000000000000..85bf5c3f3520
--- /dev/null
+++ b/sys-fs/fatsort/fatsort-1.6.4.625.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+DESCRIPTION="Sorts files on FAT16/32 partitions, ideal for basic audio players"
+HOMEPAGE="http://fatsort.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_prepare() {
+ default
+
+ sed -i -e 's|/usr/local|/usr|g' \
+ $(find ./ -name Makefile || die) || die
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) LD=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" \
+ man
+}
+
+src_test() {
+ # Tests require root permissions and mounting filesystems which does
+ # not work inside the ebuild environment
+ true
+}