summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-07-16 17:14:51 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-07-16 20:21:01 +0200
commita6f6f5b96f9c7109f91125ce4bce3868444604f4 (patch)
tree383713a662f85f6161dc61711b5acc074b83bc95 /sys-fs
parentapp-admin/sshguard: Version 2.2.0. (diff)
downloadgentoo-a6f6f5b96f9c7109f91125ce4bce3868444604f4.tar.gz
gentoo-a6f6f5b96f9c7109f91125ce4bce3868444604f4.tar.bz2
gentoo-a6f6f5b96f9c7109f91125ce4bce3868444604f4.zip
sys-fs/xfsprogs: Revbumps to add "icu" USE flag. Removed old.
This removes automagic dep on dev-libs/icu. Package-Manager: Portage-2.3.42, Repoman-2.3.9
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.16.1-r1.ebuild (renamed from sys-fs/xfsprogs/xfsprogs-4.16.1.ebuild)5
-rw-r--r--sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild (renamed from sys-fs/xfsprogs/xfsprogs-4.17.0.ebuild)5
2 files changed, 8 insertions, 2 deletions
diff --git a/sys-fs/xfsprogs/xfsprogs-4.16.1.ebuild b/sys-fs/xfsprogs/xfsprogs-4.16.1-r1.ebuild
index 275a8f8ef898..273db91aea0b 100644
--- a/sys-fs/xfsprogs/xfsprogs-4.16.1.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-4.16.1-r1.ebuild
@@ -12,10 +12,11 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="libedit nls readline static static-libs"
+IUSE="icu libedit nls readline static static-libs"
REQUIRED_USE="static? ( static-libs )"
LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ icu? ( dev-libs/icu:=[static-libs(+)] )
readline? ( sys-libs/readline:0=[static-libs(+)] )
!readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
@@ -68,8 +69,10 @@ src_configure() {
local myconf=(
--disable-lto #655638
+ --enable-blkid
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
$(use_enable nls gettext)
$(use_enable readline)
$(usex readline --disable-editline $(use_enable libedit editline))
diff --git a/sys-fs/xfsprogs/xfsprogs-4.17.0.ebuild b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
index 275a8f8ef898..273db91aea0b 100644
--- a/sys-fs/xfsprogs/xfsprogs-4.17.0.ebuild
+++ b/sys-fs/xfsprogs/xfsprogs-4.17.0-r1.ebuild
@@ -12,10 +12,11 @@ SRC_URI="https://www.kernel.org/pub/linux/utils/fs/xfs/${PN}/${P}.tar.xz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="libedit nls readline static static-libs"
+IUSE="icu libedit nls readline static static-libs"
REQUIRED_USE="static? ( static-libs )"
LIB_DEPEND=">=sys-apps/util-linux-2.17.2[static-libs(+)]
+ icu? ( dev-libs/icu:=[static-libs(+)] )
readline? ( sys-libs/readline:0=[static-libs(+)] )
!readline? ( libedit? ( dev-libs/libedit[static-libs(+)] ) )"
RDEPEND="!static? ( ${LIB_DEPEND//\[static-libs(+)]} )
@@ -68,8 +69,10 @@ src_configure() {
local myconf=(
--disable-lto #655638
+ --enable-blkid
--with-crond-dir="${EPREFIX}/etc/cron.d"
--with-systemd-unit-dir="$(systemd_get_systemunitdir)"
+ $(use_enable icu libicu)
$(use_enable nls gettext)
$(use_enable readline)
$(usex readline --disable-editline $(use_enable libedit editline))