summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-05-11 23:46:06 -0500
committerTim Harder <radhermit@gentoo.org>2019-05-11 23:51:40 -0500
commitb057a831a3f5ac46fe795b48d4bc2b2805df1726 (patch)
tree784df6458b815088a36a4bc56760bef0ad731149 /sys-fs
parentapp-portage/genlop: Correctly filter sandboxes. (diff)
downloadgentoo-b057a831a3f5ac46fe795b48d4bc2b2805df1726.tar.gz
gentoo-b057a831a3f5ac46fe795b48d4bc2b2805df1726.tar.bz2
gentoo-b057a831a3f5ac46fe795b48d4bc2b2805df1726.zip
sys-fs/rar2fs: fix build with newer unrar that drops static libs
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild b/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
new file mode 100644
index 000000000000..3860f0c11dbf
--- /dev/null
+++ b/sys-fs/rar2fs/rar2fs-1.27.2-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A FUSE based filesystem that can mount one or multiple RAR archive(s)"
+HOMEPAGE="https://hasse69.github.io/rar2fs/ https://github.com/hasse69/rar2fs"
+SRC_URI="https://github.com/hasse69/${PN}/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+# Note that upstream unrar sometimes breaks ABI without updating the SONAME
+# version so try rebuilding rar2fs if it doesn't work following an unrar
+# upgrade.
+RDEPEND=">=app-arch/unrar-5:=
+ sys-fs/fuse:0"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ export USER_CFLAGS="${CFLAGS}"
+
+ econf \
+ --with-unrar=/usr/include/libunrar \
+ --disable-static-unrar \
+ $(use_enable debug)
+}