summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-11-16 16:55:58 -0500
committerAnthony G. Basile <blueness@gentoo.org>2015-11-16 16:55:58 -0500
commitbc4daf2825744020bcc5393c1da400f7e48785e4 (patch)
treeff9a3639a24d2bf4c69d43fb1e5a897e32780315 /sys-fs
parentsys-cluster/nova: updating liberty caps (diff)
downloadgentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.tar.gz
gentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.tar.bz2
gentoo-bc4daf2825744020bcc5393c1da400f7e48785e4.zip
sys-fs/f2fs-tools: version bump to 1.5.0, bug #565938
We add subslot SLOT="0/0" in anticipation of possible bumps to the SONAME in the future. Package-Manager: portage-2.2.20.1
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/f2fs-tools/Manifest1
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/Manifest b/sys-fs/f2fs-tools/Manifest
index 79349caa5f68..026e92f52bba 100644
--- a/sys-fs/f2fs-tools/Manifest
+++ b/sys-fs/f2fs-tools/Manifest
@@ -3,3 +3,4 @@ DIST f2fs-tools-1.2.0.tar.gz 369183 SHA256 c81f0beacde34ba3ce8c1758181aca697ff46
DIST f2fs-tools-1.3.0.tar.gz 725918 SHA256 82495872cfcbdade12aeb30f1c62492f5a26ce795af49df6d86441d03e175183 SHA512 c583b8c3296bd7cf98ddaab85cd6a0ff98325b519dda084e5a5da0ff77fc99de10a1d8e645030306d93b45be32a0158f241ca277f2517bcc33dd56957ea4948d WHIRLPOOL 6002eaacef7f02c81c569337a6524129838c8a9da444cddc0711e24558b133a950547abd5de05d9a3d840901918217843081782d439dcf83f77657d3477b0c28
DIST f2fs-tools-1.4.0.tar.gz 397121 SHA256 851dd817a4c4a700383cf90a8d6f3333956cb154589daa2d6e482351ebf612bf SHA512 4d4c278d4fea25a6216ebbcbbcb88a424b16ef4d1fb1d56d186decb0f9e652f64c24f5bc7491fae360db52dbaccf8e14fb9fa9fdf86eb7025d0988e5647e17e8 WHIRLPOOL c6a53500ee86e953c31cc48e5fa2e5b8a68e55c25a33dd838f972cbdba1ff89792a801dc058425e96055f17a74c29fcfb1bd8ee747c754a44fcbba35973ac54b
DIST f2fs-tools-1.4.1.tar.gz 403406 SHA256 194fd86283b6242fbae9f639bc5e4cf746e0f0525de5a8cc7eead8a03d5e31aa SHA512 75a74999a8387c3793252b06638174866d243706f596f86d33f6c3921d52e854354364c98a4692c7aaad49121b71ad3e7a6a2e82702b5d6965e984500eeaf7ab WHIRLPOOL 5d3250dae07cdb17857bc341f38fc1c1832c8e30d5704d57f65e7f00cedc052684681577440dfd47a491f00a0f678a82d15e5907cdd0e9b92a624954114967c9
+DIST f2fs-tools-1.5.0.tar.xz 274720 SHA256 3a680a0c5ab30b7c83ce98d2919b59516d31bf2e733848e1c6bab49b07d8026c SHA512 b6596224f6922d0ad3e6801aab0921200dffd686e2438a0ab945b4902ea27b6e0baf6dcfcb66fe90ee51ee4cf10b207b031e3ef1019823ac05abc4db22660459 WHIRLPOOL b471b4ded5a11a1ce50484316c272d814e36dc90dfc45e359567ea68e27b562a1905c1b4f0575dc3f5fcd9cb25059c1d0d598a4b75798c893b9a8aa30e4eb335
diff --git a/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild b/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild
new file mode 100644
index 000000000000..7d8c8ba0fce8
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-1.5.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit multilib
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/?p=linux/kernel/git/jaegeuk/f2fs-tools.git;a=summary"
+SRC_URI="https://dev.gentoo.org/~blueness/f2fs-tools/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0/0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+IUSE=""
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf --prefix=/ --includedir=/usr/include
+}
+
+src_install() {
+ default
+ rm -f "${ED}"/$(get_libdir)/libf2fs.{,l}a
+}