summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorEric Joldasov <bratishkaerik@getgoogleoff.me>2022-11-07 20:40:33 +0600
committerSam James <sam@gentoo.org>2022-11-08 04:07:59 +0000
commitc91927b57a644d3625554a9506239e7d5a230771 (patch)
tree341ec2c30b27359f8a7a712b90f8ce1f4983322a /sys-fs
parentsys-fs/ncdu-bin: add 2.2.1 (diff)
downloadgentoo-c91927b57a644d3625554a9506239e7d5a230771.tar.gz
gentoo-c91927b57a644d3625554a9506239e7d5a230771.tar.bz2
gentoo-c91927b57a644d3625554a9506239e7d5a230771.zip
sys-fs/ncdu: add 2.2.1
Signed-off-by: Eric Joldasov <bratishkaerik@getgoogleoff.me> Closes: https://github.com/gentoo/gentoo/pull/28178 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/ncdu/Manifest2
-rw-r--r--sys-fs/ncdu/ncdu-2.2.1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/ncdu/Manifest b/sys-fs/ncdu/Manifest
index 1515990d12c8..78d477465b48 100644
--- a/sys-fs/ncdu/Manifest
+++ b/sys-fs/ncdu/Manifest
@@ -1,3 +1,5 @@
DIST ncdu-1.17.tar.gz 157187 BLAKE2B 7d36a648b8fb0a26d3b6bcc533ed8f510e7f37b3084cb585a0c785d73fd82f537e0f2f9493c3b56173eae1324255e7acf7617a1cd1614c92a3b7bf0d53b7d77f SHA512 aa2366797760f0c0b2bea866f0ae0446b8113e3ff6460192a4a42d4d888d473d7f37bc4acff6220fa86003bd96d71761168a2ae0ded36456072176a69564c775
DIST ncdu-2.1.2.tar.gz 52702 BLAKE2B fb64058bec2e8f286fa82e16986cddd9126e5c94d513740d48ff1c971e7ee95270fe6c1cfbbe240bb8e99fba4e3fd6d2624f99870422835da44447a2507f0b8b SHA512 ff48f2b9625e1aba29e5598051d16c4b5dc1a634fab897709226dd69d3b48031e6e62527c8514ec4753874d2d96800e538d6ad90b4a5f9851410d10579ccc67c
+DIST ncdu-2.2.1-upstream-zig-0.10-updates-r1.patch 47546 BLAKE2B e805010c5d575ac01cc02794905ec08185cf7bc2810571b18021bedca9c7d1079f3d8206295da307c5db70b661b9fd85a35172f8ee1495c88cdb7e52a32ad697 SHA512 a5f703db236842f54f8ce91eadd513283a1c721fa5a2ab00e38f0b7b96e3becf3e086ad43e4284abe6712113ecb3ba3a7c0d149baa3eb16b52d84a7b7a976424
+DIST ncdu-2.2.1.tar.gz 55972 BLAKE2B ac7f281b2fd12144a3498b105594a60478c49049eabeb7b3951c4aac4d5b9c025f823806dc948327e4a6608e629da9d7b15a8073bdb79043116ba095d3becdce SHA512 63a3b0d12c1c265d826276a01b37f7785d50721da5dc35c2934ee6ba7923254c02ab906bc49df60b26b8bf18b7d4c49b0cc02eb7e805cf32cde3e0cd35187973
DIST ncdu-2.2.tar.gz 55903 BLAKE2B 568760748ec54b193f17e31fa285d95085389a4f8e1abfe8e5fe5e2d67b0ca221cb7ca94cba248206808d6369058384286de690338f67faee7ff18f09832ebd9 SHA512 d491976b5e19726afe856860e07974c9c70b161c96cd17960a9f36dbc6fc1a51fd3d84da2e22e21cd3d384ab004a7d248096212e762d1ad3849e2cf8a036fc19
diff --git a/sys-fs/ncdu/ncdu-2.2.1.ebuild b/sys-fs/ncdu/ncdu-2.2.1.ebuild
new file mode 100644
index 000000000000..ee095fee9c6f
--- /dev/null
+++ b/sys-fs/ncdu/ncdu-2.2.1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="NCurses Disk Usage"
+HOMEPAGE="https://dev.yorhel.nl/ncdu/"
+SRC_URI="
+ https://dev.yorhel.nl/download/${P}.tar.gz
+ https://codeberg.org/BratishkaErik/distfiles/media/branch/master/${P}-upstream-zig-0.10-updates-r1.patch
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+PATCHES=(
+ "${DISTDIR}/${P}-upstream-zig-0.10-updates-r1.patch"
+)
+
+DEPEND="sys-libs/ncurses:=[unicode(+)]"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ || ( ~dev-lang/zig-0.10.0 ~dev-lang/zig-bin-0.10.0 )
+ virtual/pkgconfig
+"
+
+# see https://github.com/ziglang/zig/issues/3382
+# For now, Zig doesn't support CFLAGS/LDFLAGS/etc.
+QA_FLAGS_IGNORED="usr/bin/ncdu"
+
+src_test() {
+ zig build test || die "Tests failed"
+}
+
+src_install() {
+ emake PREFIX="${ED}"/usr install
+
+ dodoc README.md ChangeLog
+}