summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorJakov Smolic <jakov.smolic@sartura.hr>2021-04-29 23:27:31 +0100
committerSam James <sam@gentoo.org>2021-05-04 22:17:14 +0000
commitd65a3ae8fbb248d8c8d13732e9d6406aa6710a44 (patch)
tree9db109c2c207c2f229768f1f3249bf42d78c00ad /sys-fs
parentnet-wireless/bss: Update metadata (diff)
downloadgentoo-d65a3ae8fbb248d8c8d13732e9d6406aa6710a44.tar.gz
gentoo-d65a3ae8fbb248d8c8d13732e9d6406aa6710a44.tar.bz2
gentoo-d65a3ae8fbb248d8c8d13732e9d6406aa6710a44.zip
sys-fs/archivemount: Respect CFLAGS
Closes: https://bugs.gentoo.org/725998 Signed-off-by: Jakov Smolic <jakov.smolic@sartura.hr> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/archivemount/archivemount-0.8.12.ebuild19
1 files changed, 15 insertions, 4 deletions
diff --git a/sys-fs/archivemount/archivemount-0.8.12.ebuild b/sys-fs/archivemount/archivemount-0.8.12.ebuild
index d987a19f01ed..793dfba16b56 100644
--- a/sys-fs/archivemount/archivemount-0.8.12.ebuild
+++ b/sys-fs/archivemount/archivemount-0.8.12.ebuild
@@ -1,8 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+inherit autotools
+
DESCRIPTION="Mount archives using libarchive and FUSE"
HOMEPAGE="https://www.cybernoia.de/software/archivemount.html https://github.com/cybernoid/archivemount"
SRC_URI="https://www.cybernoia.de/software/archivemount/${P}.tar.gz"
@@ -11,7 +13,16 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-RDEPEND="app-arch/libarchive:=
+RDEPEND="
+ app-arch/libarchive:=
sys-fs/fuse:0"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+src_prepare() {
+ default
+
+ # https://bugs.gentoo.org/725998
+ sed -i -e 's/CFLAGS=//g' configure.ac || die
+ eautoreconf
+}