summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorHarry Kurn <alternate-se7en@pm.me>2022-08-15 08:05:08 +0700
committerAnthony G. Basile <blueness@gentoo.org>2022-08-16 09:51:21 -0400
commite0fee33fc6aa312e2ca62ace9c05cf2eafd64b97 (patch)
tree618dfd59cb3dd524a1e70d3d027fc54cd81dbeed /sys-fs
parentdev-cpp/sdbus-c++: Bump to 1.2.0, bump systemd to fix glibc 2.36, drop old 1.1.0 (diff)
downloadgentoo-e0fee33fc6aa312e2ca62ace9c05cf2eafd64b97.tar.gz
gentoo-e0fee33fc6aa312e2ca62ace9c05cf2eafd64b97.tar.bz2
gentoo-e0fee33fc6aa312e2ca62ace9c05cf2eafd64b97.zip
sys-fs/f2fs-tools: add live ebuild
Signed-off-by: Harry Kurn <alternate-se7en@pm.me> Signed-off-by: Anthony G. Basile <blueness@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/f2fs-tools/f2fs-tools-9999.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
new file mode 100644
index 000000000000..106339c983bf
--- /dev/null
+++ b/sys-fs/f2fs-tools/f2fs-tools-9999.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3 autotools
+
+DESCRIPTION="Tools for Flash-Friendly File System (F2FS)"
+HOMEPAGE="https://git.kernel.org/cgit/linux/kernel/git/jaegeuk/f2fs-tools.git/about/"
+EGIT_REPO_URI="https://git.kernel.org/pub/scm/linux/kernel/git/jaegeuk/${PN}.git"
+EGIT_BRANCH="dev"
+
+LICENSE="GPL-2"
+SLOT="0/9"
+IUSE="selinux"
+
+RDEPEND="
+ selinux? ( sys-libs/libselinux )
+ elibc_musl? ( sys-libs/queue-standalone )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ #This is required to install to /sbin, bug #481110
+ econf \
+ --bindir="${EPREFIX}"/sbin \
+ --disable-static \
+ $(use_with selinux)
+}
+
+src_install() {
+ default
+ find "${D}" -name "*.la" -delete || die
+}