summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2018-08-22 01:05:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-08-22 01:07:16 +0200
commitf1720a2749e166c7324e6a89b6884517ffe2a3dc (patch)
tree4839deab0d057ab3d69c24fbd75eac78c8be9292 /sys-fs
parentsys-libs/e2fsprogs-libs: bump to v1.44.4 (diff)
downloadgentoo-f1720a2749e166c7324e6a89b6884517ffe2a3dc.tar.gz
gentoo-f1720a2749e166c7324e6a89b6884517ffe2a3dc.tar.bz2
gentoo-f1720a2749e166c7324e6a89b6884517ffe2a3dc.zip
sys-fs/e2fsprogs: bump to v1.44.4
Package-Manager: Portage-2.3.48, Repoman-2.3.10
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/e2fsprogs/Manifest1
-rw-r--r--sys-fs/e2fsprogs/e2fsprogs-1.44.4.ebuild138
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-fs/e2fsprogs/Manifest b/sys-fs/e2fsprogs/Manifest
index 5a7fb9e82768..adc2d6c080b7 100644
--- a/sys-fs/e2fsprogs/Manifest
+++ b/sys-fs/e2fsprogs/Manifest
@@ -3,3 +3,4 @@ DIST e2fsprogs-1.43.6.tar.gz 7466907 BLAKE2B 6c19c686432b7990900b239c4a1b3b6675b
DIST e2fsprogs-1.43.9.tar.gz 7470878 BLAKE2B dcc1a6fda87884a0b3b1d49f4116be060bf39c4820246ba6aa7ce61c6735415542f852b36d3c809b2b52782de2ca9ea9a87086a0d4ff71ee217845939aae00f1 SHA512 7bdc5da165b14e6779aedd9243175018ca8cb2bb0f5aad9c3d04f7e0619da2107f37929e6d8027b682145801106f97d1376345c4c30ce64f2b02b716b0c4ba3b
DIST e2fsprogs-1.44.2.tar.gz 7562398 BLAKE2B a828cb9f5f3ee1579a2c5b29ef0eaf0e5696e2bf27a639cf1bf27b8d334bbbd1d142588e53e359934338f2ec95d06343a42b7c2fbd44dd6e01b348958aae3189 SHA512 d416e14a69f3e2e4ea2f4563764c422cc63400bcd514ddb12ebda6456ef04cff523da215664ede1329183acc22246111016e1abd92ff604a23e015e066dd379a
DIST e2fsprogs-1.44.3.tar.gz 7570472 BLAKE2B be713a388e3de73c0f21c85ababcf0a63aa654c988106bd38b21db6d4566915afb201ce1a3c6d55c9a300880e2b39b1702e8463c478bad51749482f379e4d844 SHA512 6203a24e5149de5b6d44cc158f9ed1d87c3083a2b41c5249ceb09fb3cdf795ab3839d7d8ce73d4b0e11d4c505b961ff8cbf0de45b9aab0a03d504750fc7da885
+DIST e2fsprogs-1.44.4.tar.xz 5363496 BLAKE2B 8c7216bd63dbba0660c7383d6ed068be0a7016b50235d22f855283bb57d3355a3ea5bfa47294b71b67fcc5d4af28219abeb9cf4a6429595a43680d3d787bdf1a SHA512 52e39565dee30997b9c245b5d8791844067a903a570082f3a5ff9d9ef96624535322617bb21029056c88259fef46416eb1181bd7aec419e64fc021830887ec8f
diff --git a/sys-fs/e2fsprogs/e2fsprogs-1.44.4.ebuild b/sys-fs/e2fsprogs/e2fsprogs-1.44.4.ebuild
new file mode 100644
index 000000000000..87bab9113498
--- /dev/null
+++ b/sys-fs/e2fsprogs/e2fsprogs-1.44.4.ebuild
@@ -0,0 +1,138 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+
+inherit flag-o-matic multilib toolchain-funcs
+
+DESCRIPTION="Standard EXT2/EXT3/EXT4 filesystem utilities"
+HOMEPAGE="http://e2fsprogs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/e2fsprogs/${P}.tar.xz
+ mirror://kernel/linux/kernel/people/tytso/e2fsprogs/v${PV}/${P}.tar.xz
+ elibc_mintlib? ( mirror://gentoo/${PN}-1.42.9-mint-r1.patch.xz )"
+
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 -x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~m68k-mint"
+IUSE="fuse nls static-libs elibc_FreeBSD"
+
+RDEPEND="~sys-libs/${PN}-libs-${PV}
+ >=sys-apps/util-linux-2.16
+ fuse? ( sys-fs/fuse:0 )
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )
+ virtual/pkgconfig
+ sys-apps/texinfo"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.41.8-makefile.patch
+ "${FILESDIR}"/${PN}-1.40-fbsd.patch
+ "${FILESDIR}"/${PN}-1.42.13-fix-build-cflags.patch #516854
+
+ # Upstream patches (can usually removed with next version bump)
+)
+
+src_prepare() {
+ if [[ ${CHOST} == *-mint* ]] ; then
+ PATCHES+=( "${WORKDIR}"/${PN}-1.42.9-mint-r1.patch )
+ fi
+
+ default
+
+ cp doc/RelNotes/v${PV}.txt ChangeLog || die "Failed to copy Release Notes"
+
+ # Get rid of doc -- we don't use them. This also prevents a sandbox
+ # violation due to mktexfmt invocation
+ rm -r doc || die "Failed to remove doc dir"
+
+ # blargh ... trick e2fsprogs into using e2fsprogs-libs
+ sed -i -r \
+ -e 's:@LIBINTL@:@LTLIBINTL@:' \
+ -e '/^(STATIC_)?LIB(COM_ERR|SS)/s:[$][(]LIB[)]/lib([^@]*)@(STATIC_)?LIB_EXT@:-l\1:' \
+ -e '/^DEP(STATIC_)?LIB(COM_ERR|SS)/s:=.*:=:' \
+ MCONFIG.in || die "muck libs" #122368
+ sed -i -r \
+ -e '/^LIB_SUBDIRS/s:lib/(et|ss)::g' \
+ Makefile.in || die "remove subdirs"
+ ln -s $(which mk_cmds) lib/ss/ || die
+
+ # Avoid rebuild
+ echo '#include_next <ss/ss_err.h>' > lib/ss/ss_err.h
+}
+
+src_configure() {
+ # Keep the package from doing silly things #261411
+ export VARTEXFONTS="${T}/fonts"
+
+ # needs open64() prototypes and friends
+ append-cppflags -D_GNU_SOURCE
+
+ local myeconfargs=(
+ --with-root-prefix="${EPREFIX%/}/"
+ --enable-symlink-install
+ --enable-elf-shlibs
+ $(tc-has-tls || echo --disable-tls)
+ --without-included-gettext
+ $(use_enable fuse fuse2fs)
+ $(use_enable nls)
+ --disable-libblkid
+ --disable-libuuid
+ --disable-fsck
+ --disable-uuidd
+ )
+ ac_cv_path_LDCONFIG=: econf "${myeconfargs[@]}"
+
+ if [[ ${CHOST} != *-uclibc ]] && grep -qs 'USE_INCLUDED_LIBINTL.*yes' config.{log,status} ; then
+ eerror "INTL sanity check failed, aborting build."
+ eerror "Please post your ${S}/config.log file as an"
+ eerror "attachment to https://bugs.gentoo.org/show_bug.cgi?id=81096"
+ die "Preventing included intl cruft from building"
+ fi
+}
+
+src_compile() {
+ emake V=1 COMPILE_ET=compile_et MK_CMDS=mk_cmds
+
+ # Build the FreeBSD helper
+ if use elibc_FreeBSD ; then
+ cp "${FILESDIR}"/fsck_ext2fs.c .
+ emake V=1 fsck_ext2fs
+ fi
+}
+
+src_install() {
+ # need to set root_libdir= manually as any --libdir options in the
+ # econf above (i.e. multilib) will screw up the default #276465
+ emake \
+ STRIP=: \
+ root_libdir="${EPREFIX%/}/usr/$(get_libdir)" \
+ DESTDIR="${D%/}" \
+ install install-libs
+
+ einstalldocs
+
+ insinto /etc
+ doins "${FILESDIR}"/e2fsck.conf
+
+ # Move shared libraries to /lib/, install static libraries to
+ # /usr/lib/, and install linker scripts to /usr/lib/.
+ gen_usr_ldscript -a e2p ext2fs
+
+ # configure doesn't have an option to disable static libs :/
+ if ! use static-libs ; then
+ find "${D}" -name '*.a' -delete || die
+ fi
+
+ if use elibc_FreeBSD ; then
+ # Install helpers for us
+ into /
+ dosbin "${S}"/fsck_ext2fs
+ doman "${FILESDIR}"/fsck_ext2fs.8
+
+ # filefrag is linux only
+ rm \
+ "${ED%/}"/usr/sbin/filefrag \
+ "${ED%/}"/usr/share/man/man8/filefrag.8 || die
+ fi
+}