summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-19 07:54:49 +0100
committerSam James <sam@gentoo.org>2021-04-19 20:10:17 +0100
commitf4b609005c7cb5f2512e25dadf92f7ba377dd39b (patch)
tree6022a5270a74c04322e07f6d0930979590f3805e /sys-fs
parentsys-apps/pcsc-slb-rf72-drv: respect PKG_CONFIG (diff)
downloadgentoo-f4b609005c7cb5f2512e25dadf92f7ba377dd39b.tar.gz
gentoo-f4b609005c7cb5f2512e25dadf92f7ba377dd39b.tar.bz2
gentoo-f4b609005c7cb5f2512e25dadf92f7ba377dd39b.zip
sys-fs/davl: respect PKG_CONFIG
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/davl/davl-1.2.4-r2.ebuild4
-rw-r--r--sys-fs/davl/files/davl-1.2.1-asneeded.patch4
2 files changed, 5 insertions, 3 deletions
diff --git a/sys-fs/davl/davl-1.2.4-r2.ebuild b/sys-fs/davl/davl-1.2.4-r2.ebuild
index 0fdc23693d0f..d91a538ee69d 100644
--- a/sys-fs/davl/davl-1.2.4-r2.ebuild
+++ b/sys-fs/davl/davl-1.2.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -24,6 +24,8 @@ PATCHES=(
)
src_compile() {
+ tc-export PKG_CONFIG
+
emake CC="$(tc-getCC)"
}
diff --git a/sys-fs/davl/files/davl-1.2.1-asneeded.patch b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
index 819d16d09e75..58646e7dd492 100644
--- a/sys-fs/davl/files/davl-1.2.1-asneeded.patch
+++ b/sys-fs/davl/files/davl-1.2.1-asneeded.patch
@@ -26,8 +26,8 @@
-else
- CFLAGS += $(CFLAGS1)
-endif
-+CFLAGS += -D$(GTK_VER) `pkg-config --cflags gtk+-2.0`
-+LDLIBS = `pkg-config --libs gtk+-2.0`
++CFLAGS += -D$(GTK_VER) `${PKG_CONFIG} --cflags gtk+-2.0`
++LDLIBS = `${PKG_CONFIG} --libs gtk+-2.0`
DEBUG =
#DEBUG = -D DEBUG
GDAVL = gdavl