summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-18 06:48:44 +0100
committerMichał Górny <mgorny@gentoo.org>2023-03-18 06:53:59 +0100
commitf95bef0949e859f4a4b01242b07343fa79374fba (patch)
tree6ed502b3f44a243c977a1d73477db1eaa92039e7 /sys-fs
parentapp-admin/awscli: Bump to 1.27.94 (diff)
downloadgentoo-f95bef0949e859f4a4b01242b07343fa79374fba.tar.gz
gentoo-f95bef0949e859f4a4b01242b07343fa79374fba.tar.bz2
gentoo-f95bef0949e859f4a4b01242b07343fa79374fba.zip
sys-fs/squashfs-tools: Bump to 4.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/squashfs-tools/Manifest1
-rw-r--r--sys-fs/squashfs-tools/squashfs-tools-4.6.ebuild57
2 files changed, 58 insertions, 0 deletions
diff --git a/sys-fs/squashfs-tools/Manifest b/sys-fs/squashfs-tools/Manifest
index 74ac243af627..f23877e9773e 100644
--- a/sys-fs/squashfs-tools/Manifest
+++ b/sys-fs/squashfs-tools/Manifest
@@ -1 +1,2 @@
DIST squashfs-tools-4.5.1.tar.gz 270112 BLAKE2B cbd35daf582d284b021911bb754ed548763f2773e1bc02516ca18bab7034e352780c11eb7dfed1f047b70974dcfb716bb1a1d3729e5b25662203cfbf93553b73 SHA512 b3934ea1e26c7508110312711465644a6d9674b6b5332a7d011e191fa3c1d4b8be694214794a0f6005263d0f4e18bab96af2f7ed66a178f8e3bb3a781cd44896
+DIST squashfs-tools-4.6.tar.gz 286409 BLAKE2B 1c04a8f6149863667151e76b3c1ecfdd5e9a181b305bea694af1d4968ac361114c9e926b351dcee2647796a21bc8cfc55b3d95f020ad88c3388007460de26053 SHA512 3a9effb9a5cf46fbb9f393e58bd938874dc4121828b77c67d659117ee84643917998a8503d629f46f1eff1826f6d7ae59ac2d803a5cdc3cfb1006ef2b3abf8c8
diff --git a/sys-fs/squashfs-tools/squashfs-tools-4.6.ebuild b/sys-fs/squashfs-tools/squashfs-tools-4.6.ebuild
new file mode 100644
index 000000000000..896db57a6f33
--- /dev/null
+++ b/sys-fs/squashfs-tools/squashfs-tools-4.6.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Tools to create and extract Squashfs filesystems"
+HOMEPAGE="https://github.com/plougher/squashfs-tools/"
+SRC_URI="
+ https://github.com/plougher/squashfs-tools/archive/${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="debug lz4 lzma lzo xattr zstd"
+
+DEPEND="
+ sys-libs/zlib
+ lz4? ( app-arch/lz4 )
+ lzma? ( app-arch/xz-utils )
+ lzo? ( dev-libs/lzo )
+ xattr? ( sys-apps/attr )
+ zstd? ( app-arch/zstd )
+"
+RDEPEND=${DEPEND}
+
+use10() {
+ usex "${1}" 1 0
+}
+
+src_compile() {
+ # set up make command line variables in EMAKE_SQUASHFS_CONF
+ local opts=(
+ LZMA_XZ_SUPPORT=$(use10 lzma)
+ LZO_SUPPORT=$(use10 lzo)
+ LZ4_SUPPORT=$(use10 lz4)
+ XATTR_SUPPORT=$(use10 xattr)
+ XZ_SUPPORT=$(use10 lzma)
+ ZSTD_SUPPORT=$(use10 zstd)
+ )
+
+ tc-export CC
+ use debug && append-cppflags -DSQUASHFS_TRACE
+ emake "${opts[@]}" -C squashfs-tools
+}
+
+src_install() {
+ dobin squashfs-tools/{mksquashfs,unsquashfs}
+ dodoc ACKNOWLEDGEMENTS CHANGES README*
+ doman manpages/*.1
+
+ dosym unsquashfs /usr/bin/sqfscat
+ dosym mksquashfs /usr/bin/sqfstar
+}