summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkuzetsa <kuzetsa@gmail.com>2018-01-05 16:45:36 -0500
committerGöktürk Yüksek <gokturk@gentoo.org>2018-01-05 17:35:50 -0500
commit19b3263f6d5b60b89c06c140a6fc831da84665eb (patch)
tree5daa50211fdef1666e04b65b35ca996ebf3edad3 /sys-kernel/ck-sources/ck-sources-4.14.12.ebuild
parentprofiles: Add LINGUAS to info_vars. (diff)
downloadgentoo-19b3263f6d5b60b89c06c140a6fc831da84665eb.tar.gz
gentoo-19b3263f6d5b60b89c06c140a6fc831da84665eb.tar.bz2
gentoo-19b3263f6d5b60b89c06c140a6fc831da84665eb.zip
sys-kernel/ck-sources: v.bump (4.14.12)
Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.14.12.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.14.12.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.14.12.ebuild b/sys-kernel/ck-sources/ck-sources-4.14.12.ebuild
new file mode 100644
index 000000000000..cd28f080ec0a
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.14.12.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="17"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
+
+CK_VERSION="1"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${CK_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ # linux-info eclass cannot handle recursively expanded variables in Makefile #490328
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile" || die
+
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ elog "ck-sources previously enabled CPU optimizations by default."
+ elog "USE=\"experimental\" is now required to enable this patch."
+ elog "this can be set in /etc/portage/package.use (or make.conf)"
+}