summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkuzetsa <kuzetsa@gmail.com>2017-12-05 13:36:54 -0500
committerMichael Palimaka <kensington@gentoo.org>2017-12-06 23:31:58 +1100
commit419ffb0785df95cf1463ad3ddf6981ced95a4a79 (patch)
treecc6138a00e9a0b178aaee0c2af48952f8f6a6adf /sys-kernel/ck-sources/ck-sources-4.14.4.ebuild
parentsys-kernel/ck-sources: experimental USE handling / 4.13 EOL (diff)
downloadgentoo-419ffb0785df95cf1463ad3ddf6981ced95a4a79.tar.gz
gentoo-419ffb0785df95cf1463ad3ddf6981ced95a4a79.tar.bz2
gentoo-419ffb0785df95cf1463ad3ddf6981ced95a4a79.zip
sys-kernel/ck-sources: v.bump (4.9.67 & 4.14.4)
4.9 branch: simple bump 4.14 branch: squashed earlier -r1 commit: user-facing einfo message for genpatches-related USE removal of legacy K_EXP_* (workaround) behavior converted to IUSE experimental (via kernel-2.eclass) Closes: https://github.com/gentoo/gentoo/pull/6428 Package-Manager: Portage-2.3.13, Repoman-2.3.3
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.14.4.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.14.4.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.14.4.ebuild b/sys-kernel/ck-sources/ck-sources-4.14.4.ebuild
new file mode 100644
index 000000000000..36caf42619ec
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.14.4.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="5"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Con Kolivas' high performance patchset and Gentoo's genpatches for Linux ${K_BRANCH_ID}"
+
+CK_VERSION="1"
+
+CK_FILE="patch-${K_BRANCH_ID}-ck${CK_VERSION}.xz"
+
+CK_BASE_URL="http://ck.kolivas.org/patches/4.0"
+CK_LVER_URL="${CK_BASE_URL}/${K_BRANCH_ID}/${K_BRANCH_ID}-ck${CK_VERSION}"
+CK_URI="${CK_LVER_URL}/${CK_FILE}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${CK_FILE}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+src_prepare() {
+
+#-- Comment out CK's EXTRAVERSION in Makefile ---------------------------------
+
+ # linux-info eclass cannot handle recursively expanded variables in Makefile #490328
+ sed -i -e 's/\(^EXTRAVERSION :=.*$\)/# \1/' "${S}/Makefile" || die
+
+ kernel-2_src_prepare
+}
+
+pkg_postinst() {
+ elog "ck-sources previously enabled CPU optimizations by default."
+ elog "USE=\"experimental\" is now required to enable this patch."
+ elog "this can be set in /etc/portage/package.use (or make.conf)"
+}