summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorkuzetsa <kuzetsa@gmail.com>2018-09-06 02:51:25 +0200
committerThomas Deutschmann <whissi@gentoo.org>2018-09-06 02:53:08 +0200
commit405fa2a7648f9b53c66522af11e1468c2827c734 (patch)
treee70024ff1abf20fa9956194a18882ce8238d8c1d /sys-kernel/ck-sources/ck-sources-4.18.5.ebuild
parentsys-kernel/ck-sources: genpatches-4.14-73 (diff)
downloadgentoo-405fa2a7648f9b53c66522af11e1468c2827c734.tar.gz
gentoo-405fa2a7648f9b53c66522af11e1468c2827c734.tar.bz2
gentoo-405fa2a7648f9b53c66522af11e1468c2827c734.zip
sys-kernel/ck-sources: genpatches-4.18-8
Closes: https://github.com/gentoo/gentoo/pull/9735 Package-Manager: Portage-2.3.40, Repoman-2.3.9 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.18.5.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.18.5.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.18.5.ebuild b/sys-kernel/ck-sources/ck-sources-4.18.5.ebuild
new file mode 100644
index 000000000000..b7c502b10e2c
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.18.5.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="8"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Gentoo's genpatches for Linux ${K_BRANCH_ID}, with Con Kolivas' MuQSS process scheduler."
+
+MUQSS_VERSION="173"
+MUQSS_FILE="0001-MultiQueue-Skiplist-Scheduler-version-v0.${MUQSS_VERSION}.patch"
+MUQSS_BASE_URL="http://ck.kolivas.org/patches/muqss/4.0"
+
+# clearly identify package name in distrdir
+MUQSS_DISTNAME="${PN}-${K_BRANCH_ID}-muqss.patch"
+
+CK_LVER_URL="${MUQSS_BASE_URL}/${K_BRANCH_ID}"
+CK_URI="${CK_LVER_URL}/${MUQSS_FILE} -> ${MUQSS_DISTNAME}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${MUQSS_DISTNAME}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+pkg_postinst() {
+ elog "CPU optimizations patch (from genpatches) is off by default."
+ elog "Set USE=\"experimental\" if you need this patch / feature."
+ elog "This can be set in /etc/portage/package.use (or make.conf)"
+ elog "make menuconfig as usual to edit .config for this feature."
+}