summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSarah White <kuzetsa@poindexter.ovh>2018-09-27 03:24:31 -0400
committerMichał Górny <mgorny@gentoo.org>2018-09-28 11:30:39 +0200
commita44c137b520e7a56d660343d7b4891be75a0d039 (patch)
treedeb5372be1450979896cb70c96d4406913885002 /sys-kernel/ck-sources/ck-sources-4.18.9.ebuild
parentsys-kernel/ck-sources: Bump to 4.14.71 (diff)
downloadgentoo-a44c137b520e7a56d660343d7b4891be75a0d039.tar.gz
gentoo-a44c137b520e7a56d660343d7b4891be75a0d039.tar.bz2
gentoo-a44c137b520e7a56d660343d7b4891be75a0d039.zip
sys-kernel/ck-sources: Bump to 4.18.9
Includes genpatches-4.18-12. Signed-off-by: Sarah White <kuzetsa@poindexter.ovh> Signed-off-by: Michał Górny <mgorny@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/9926
Diffstat (limited to 'sys-kernel/ck-sources/ck-sources-4.18.9.ebuild')
-rw-r--r--sys-kernel/ck-sources/ck-sources-4.18.9.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/sys-kernel/ck-sources/ck-sources-4.18.9.ebuild b/sys-kernel/ck-sources/ck-sources-4.18.9.ebuild
new file mode 100644
index 000000000000..14f9f6583e08
--- /dev/null
+++ b/sys-kernel/ck-sources/ck-sources-4.18.9.ebuild
@@ -0,0 +1,54 @@
+# Copyright 2018 kuzetsa℠ and others
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+ETYPE="sources"
+KEYWORDS="~amd64 ~x86"
+
+HOMEPAGE="https://dev.gentoo.org/~mpagano/genpatches/
+ http://kernel.kolivas.org/"
+
+IUSE="experimental"
+
+K_WANT_GENPATCHES="base extras experimental"
+K_GENPATCHES_VER="12"
+K_SECURITY_UNSUPPORTED="1"
+K_DEBLOB_AVAILABLE="1"
+
+PYTHON_COMPAT=( python2_7 )
+inherit python-any-r1 kernel-2
+detect_version
+detect_arch
+
+DEPEND="deblob? ( ${PYTHON_DEPS} )"
+
+K_BRANCH_ID="${KV_MAJOR}.${KV_MINOR}"
+
+DESCRIPTION="Gentoo's genpatches for Linux ${K_BRANCH_ID}, with Con Kolivas' MuQSS process scheduler."
+
+MUQSS_VERSION="173"
+MUQSS_FILE="0001-MultiQueue-Skiplist-Scheduler-version-v0.${MUQSS_VERSION}.patch"
+MUQSS_BASE_URL="http://ck.kolivas.org/patches/muqss/4.0"
+
+# clearly identify package name in distrdir
+MUQSS_DISTNAME="${PN}-${K_BRANCH_ID}-muqss.patch"
+
+CK_LVER_URL="${MUQSS_BASE_URL}/${K_BRANCH_ID}"
+CK_URI="${CK_LVER_URL}/${MUQSS_FILE} -> ${MUQSS_DISTNAME}"
+
+SRC_URI="${KERNEL_URI} ${GENPATCHES_URI} ${ARCH_URI} ${CK_URI}"
+
+UNIPATCH_LIST="${DISTDIR}/${MUQSS_DISTNAME}"
+UNIPATCH_STRICTORDER="yes"
+
+pkg_setup() {
+ use deblob && python-any-r1_pkg_setup
+ kernel-2_pkg_setup
+}
+
+pkg_postinst() {
+ elog "CPU optimizations patch (from genpatches) is off by default."
+ elog "Set USE=\"experimental\" if you need this patch / feature."
+ elog "This can be set in /etc/portage/package.use (or make.conf)"
+ elog "make menuconfig as usual to edit .config for this feature."
+}